Scenario Editor trigger - Change Object Icon doesn't work as expected?

Game Version:

(Steam Release)


When trying out new triggers in the Editor, I noticed the Change Object Icon trigger doesn’t seem to work properly.

Reproduction Steps:


Appears to work fine? Exact same game build and platform
Have you tried a different icon or different unit to change the icon of?

The only difference I can think of is that I put a timer of 1 second in the trigger after the game starts before the icon is changed to make sure villagers gathering resources are given the icon - perhaps the cobra car changes into a different identical unit at some point like villagers do depending on their action

Really odd, I’ll have to try again with some other units. I’ve tried twice and it didn’t work right. At one point all my icons in-game were just black, too, though I’m not sure if it’s related.

Cobra shouldn’t be switching unit ID at all…

Edit: A second attempt, this time changing a Chu to have a Cobra icon, and it worked… Perhaps it was an issue with Set Object not working?