Shift click bug after clicking on a building

I reproduced a bug of villagers not going back to work
it works like this
if you queue buildings first without clicking back to work at the end
then you try to fix it, you shift click the buildings again and then click the resources
the unit will forget the whole 2nd command queue and just build the first building and nothing else
(potentially the nearby buildings aswell, but it won’t adhere to the 2nd queue up of commands)

1 Like

I can’t reproduce this. Here’s what I tried:

  1. Get idle villager to shift build 3 houses.
  2. Deselect villager.
  3. Select villager and shift queue the 3 houses and then a resource gather spot

The villager will go to the resource point like you expect after building the 3 houses. The only weird thing is they seem to go into an idle loop for a second while the game checks that the buildings are already finished. You can see the villager standing on the spot going in and out of idle for a few seconds.

What’s wrong with the steps above? Why can’t I reproduce this? Does the villager need to be gathering resources at the start?

testing it myself again to isolate weird stuff

When I queue 3 barracks, then release shift, then I click the first building once, then hold shift and click the first building again, then the other 2 barracks, then the resource, I got my villager to ignore the 3rd barracks 2 out of 3 times.
He went back to the resource I clicked him though every time.
Either the bug is inconsistent (likely to do with clicking the first racks twice and triggering some smart command processing after the building is done).
Or I haven’t 100% isolated everything necessary to reproduce.

But I have other people saying in my discord they are losing some inputs aswell.

And in my multiplayer games, 100% of the time after building the age up building with 1 worker, the worker never returns to work even if I shift click him. Same when I queue 3 racks while holding shift, then releasing shift, clicking the racks again, then holding shift and click the 3 racks and clicking the resource, then releasing shift. 100% of the time I will have to manually command the villager to go to work afterwards.

Potentially villagers forget queue after a long time or if enough other units are build/queued up via buildings or something?

To summarize your problem:

  • Place blueprints of multiple buildings

  • Right click first building to remove shift que

  • Shift que the villager to build the blueprints

  • Shift que the same villager to a res

Is this what you mean?

I have noticed some problems as well but always attributed it to me misclicking the blueprint.

1 Like

Yeah I can’t reproduce the issue when I try exactly as you say (I tried with Abassid). But I have funny stuff happening too sometimes when qeueing up constructions. That I suddenly see that the villager did build some of the tasked constructions but at some random point stopped doing that and went to the last qeued task (usually gathering resources indeed). But like @SeagoingPuddle3 said I always assume it’s from me misclicking. Or building too close or in the fog of war or something.

1 Like