Shift Key Behavior Problems - Please Fix

Game Version: AoE2: DE

  • Build: 101.101.34793.0 4597979
  • Platform: Steam

Issue:

I’m wondering if there is a workaround for the Control Group hotkey changes that were made?.. The “Append” behavior was added and it seems to overrule the way I have used Control Group numbers for almost twenty years now, to give an example: If I want to assign my Knights as number “1” and my Cav Archers as number “2”, then how do I now temporarily join the two groups and later separate them with their respective number? Right now if I punch the classic keys, “1” + “Shift” + “2”, it automatically appends them and gives them the same number, which in this example would be “2” (whereas you used to have to then hit “Ctrl” + a number to do that). I am hoping I can somehow get the original Shift key functionality back.

To be extra thorough, I have just confirmed this was indeed the default Shift key behavior for the original AoC (CD Version) and in HD on Steam.

This undesirable issue has also been reported by others here:


I feel this should rightly be posted in this “Report a Bug” category, so I’ve started this thread.

I was advised that there is an option called “Selection Modifier Hotkeys” that should toggle this behavior, but this unfortunately did not have an effect on the problem described. I would really love to see this fixed, or to at least have a setting added that could be toggled on/off for desired behavior, this current setup really throws off my classic style of unit control.

Reproduction Steps:

  1. Hotkeys: set to “Classic”
  2. Hotkeys: Group Commands: “Append Group #(respective numbers)” assigned with default settings*
  3. Settings: “Selection Modifier Hotkeys” toggled on or off
  4. Start any normal game
  5. Assign unit(s) to a Control Group; e.g. Scout, “Ctrl” + “1” to assign as group #1
  6. Assign other unit(s); e.g. Villagers, “Ctrl” + “2” to assign as group #2
  7. Attempt to select both groups with classic “Shift” key controls; e.g. “1” + “Shift” + “2”
  8. Note that you cannot use “Shift” key for legacy control behavior at present, it will always reassign the Control Group numbers to be the same for the selection instead of just selecting the two groups.
  9. Try it on AoC (CD version), or HD on Steam, and note that this doesn’t change your numbers.

*Note for Step 2: if you simply clear said hotkeys it disables all applicable “Shift” key functionality.

Thanks!

4 Likes

Developers said, that all QOL changes will be toggleable, but for some reason this very annoying change is not toggleable. Why?
Same case for the trebuchet automatic packing behavior, which should also be toggleable.

Why aren’t all QOL changes toggleable, so that people can keep on playing this game in a way they are used to, like was promised?

Thank you for the amazingly detailed report! We now have a task to investigate this issue and see whether we can implement adjustments to better-support your play style. Thanks for the feedback, and to @Yorok0 for the additional notes about how we can improve the system! :slight_smile:

3 Likes

Thank you immensely for looking into this and writing a reply too!

Hopefully the fix for this issue is as simple as adding back the legacy controls alongside the new DE ones, and then just making it so a person can toggle in the options menu which behavior they want.
:grinning::+1:

1 Like

Game Version:

  • Build (####): 101.101.35209.0 4667120
  • Platform (Steam or Microsoft Store): Steam

Issue:

When doing SHIFT+<GROUP_NR>, the currently selected units get added to the group <GROUP_NR>, redefining the group. For example if you press 1 to select group 1, and then press SHIFT+2, all units from group 1 get added to group 2, and group 1 becomes empty. Thus, both groups get redefined. In previous AoE2 versions, SHIFT+<GROUP_NR> only added the group to the selection of units and did not redefine groups.
The previous way of group selection allows to efficiently control an army composed of different groups. In my opinion, the new way is useless, in previous versions, you can also quickly merge (redefine) groups by selecting two groups (2 commands: 1 and SHIFT+2) and defining a new group (+1 command: CTRL+2), vs now selecting one group (1 command: “1”) and appending it to another (+1 command: SHIFT+2).

Reproduction Steps:

See above

1 Like

I would also like to add that it is impossible to efficiently perform some army movements with the new behavior. I can’t see a way of selecting army groups (eg archers, infantry and trebuchets) without redefining groups other than dragging a selection box. However, the selection box is much slower and much more imprecise, other units (peasants, army reserves, unintended units of same type) end up in the mix.

1 Like

Is this a bug? maybe Im missing something here… why revert? I think you meant we need a toggle. Some may like the new behavior some other may not.

You can use the new QoL feature for selection boxes: CTRL + selection box = only army, ALT + selection box = only peasants.

Question to the devs:
In order to have a classic/HD experience, I removed the hotkeys for Append Group #X, and then tried the following:
-Create Group #1 (Select group of units, Ctrl+1)
-Create Group #2 (Select a different group of units, Ctrl+2)
-Clear selection
-Select group #1 (press 1)
-Try to create to add group #2 to the selection (Hold Shift + 2)
The result is the same regardless if the checkbox “Shift Group Appending” on the Game Tab in option is checked or not.

This has been 6 months in the queue, are we going to get a fix?

@gilb04
Hey there!

First up, I’m not a dev but I can confirm there is good news on this subject. :slightly_smiling_face:
In the time since this thread was started they have made updates so that it’s possible to get back that “classic experience” you are looking for. Originally I too thought that it was a matter of clearing the “Append Group #_” hotkeys but it turns out that isn’t the solution. The details can get a little confusing, but I personally do have that nice, classic, control experience on DE now and my (relevant) settings are as follows:

  • Unchecked box for “Selection Modifier Hotkeys”

  • Unchecked box for “Shift Group Appending”

  • Hotkeys -> Group Commands:
    Create Group #1 = Ctrl-1
    Select Group #1 = 1
    Append Group #1 = Shift-1
    (the number 1 above is just used as a sample number for all my individual Group number entries)

Hope that helps!

2 Likes