(SOLVED) With Oct 20th 41855 patch, Audio mod no longer works in game

:arrow_forward: GAME INFORMATION

  • BUILD #: 41855
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

with latest October 20th 2020 patch, our mod and custom audio .wem file no longer works, sound simply does not play, only core game sound still works.

things I have tried:

  1. Tried single player and multiple player, both not working
  2. no changes to mod, sound stops working
  3. separate Audio .wem into a mod of it’s own, not working
  4. once separated audio, put audio mod on highest priority, restart the game still nothing.
  5. tried different directory file path
    • mod folder > resources > _common > drs > sounds > .wem files
    • mod folder > wwise > .wem files
      both not working.
  6. tried other mods that I know has custom audio and was working prior to patch, now also no longer works.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

see above, simply play the game with no change to mod and custom audio no longer works.

1 Like

I can’t believe they actually make it worse and worse for us modders each update…
It seems like they don’t want us to create more content
Devs, please fix this asap.

1 Like

I updated that mod this weekend, my tests show no problems.
.wem files are put into \resources\en\sound\taunt

I tested other taunt mods this weekend as well with no problems…
You know a game restart is required after installing taunt mods, right?
Edit: oh there was an update today, oh god no… let me check

well how bout that, they broke it again. :rage:

1 Like

Hang on, now wait a minute
Try restarting because it’s working for me now all of a sudden

oh damn i already restarted and its no go

I can’t seem to replicate the issue anymore after restarting the game. Tried uninstalling and reinstalling, still works fine.

There may be a trick to “resetting” the taunts
Alluded to by this comment on my mod

reigenApril 27, 2020

For anyone who has the problem that the taunts don’t work, here is a solution i figured out.
Note: This works only for taunts that doesn’t replace the main taunts.

1.Find a taunt pack that already works (i dont know how to do this if you got no working pack).
2.Open both the directory of the working one and the one that doesn’t. (go to directory over the ingame mod menu or manual listed in “user/yourname/Games/Age of Empires 2 DE/number(mine is 76561197998360739)/mods/subscribed/yourtauntpack”.
3. Now you want to copy the one who’s not working to your desktop, in my case from the Gordon ramsay taunt pack the file “500 embarassing_mess.mp3_D435D2E4.wem” and rename it to the working one, that’s in my case from the Aussie Banter taunts the file “106 Yes, of course.wem” or every other one in this pack because all of them worked. Now drag the renamed gordon ramsey taunt in the aussie taunt pack and override it.
4. If you start AoeDE now the game should reset the taunts and the taunt pack that wasn’t working before should now function properly.

Note that i set my game to english and most taunt packs only use the “en” files of the game.

That’s it let me know if it helped you. hfgl

I may have triggered this same reset when I tested my old Vorbis .wem’s
Vorbis used to be the only codec that worked because the smaller PCM format was bugged, then they fixed it, so I had re-encoded to PCM to save file space.(this was months ago)
I only copied an old vorbis encoded taunt mod into my local mod folder, set its priority above the non-working one, tested it, closed the game, then relaunched and set the non-working one as higher priority, tested it and it was fine all of a sudden.
:man_shrugging: :man_shrugging: :man_shrugging:

its now working, these boxes can no longer be left at 0

1 Like