[STEAM] Deck and civs levels non consistent between different PCs

Hello there! I have an issue. I’mhaving my civs not uploading anymore from one computer to another, despite checking the files (built in tool from Steam).

For instance, with the new game mode I built a few decks for Empire Wars with my desktop pc on wednesday. But I can’t find them on my laptop which is kind of annoying…

I left both the computer on for a while, hopping that giving them some time would be enough. Didn’t work.

Any tips on how to solve this ?


Hi @Tam501e

I’m not sure, maybe this option in Steam is disabled?

Sadly I checked and it’s not disabled. Won’t be my solution but worth checking if anyone encounter this.

Oh I see, it should be something else then

We are now tracking this issue


me too,i have the same problem,and avatars

I used to have this problem. Solved it by dropping my laptop on the edge of my stairs.


I should definetly try this anytime I have a bug. :laughing:

1 Like

I think it won’t be solved until the next update. I still don’t have my civs correctly updated from one pc to the other.

Still not fixed… made me loose two empire wars today :cry:

Again this isn’t fixed yet. I’m considering deleting and re-downloading the game but my internet isn’t that fast… And the game so big I can’t do that many times.

If anything, you’d need to delete local data (%USERPROFILE%\Games\Age of Empires 3 DE), not the game installation folder, that wouldn’t help.

I just tried that and it didn’t work sadly.