Still "too early" and getting no help

Just a question, does the email of support get even checked? I already mailed multiple times my problem (with log files, even from different PCs the log files) but never got an answer or heard anything back. And I still can’t start the game, because I’m too early.
Tried all the things in the FAQ, the things posted here in the forums, but nothing helped.
As like the game has set a wrong date into my profile and I won’t be able to play till that date will come.

And getting no support at all is not consumer friendly. :frowning:

Did you try it on a fresh Windows 10 release 1803 install already?

I’m on Win10 Pro rel 1803. But I won’t install Win10 fresh just for one game and that shouldn’t be a solution at all. Way to much hassle to install all the programs I need for working again. The system got set up totally new in the middle of May… so just 1 1/2 months ago.

And just for testing, I’m deleting and installing AoE:DE again (which I did already way to often for testing purposes and on multiple PCs).

Could you post some logs here?

Here the error message and some logs:
There is no StartupLog in the folder specified on the support page
EventViewer Log

Could you try to check following:

  1. Open the Windows 10 Store, then in the top right corner click on the profile picture. If you have multiple accounts signed in, sign out all but the email account linked to the game’s purchase/pre-order.
  2. Next, locate a free Windows 10 Store download and install it. (You can uninstall it directly after).
  3. Then try playing (downloading) Age Of Empiter DE again through the Windows 10 Store “Library” page.

Tried that already, tried it again now… still too early when I try to start AoE… :neutral_face:

Any more ideas? Or won’t I ever get real support to be able to play the game?
Can someone from MS look into my profile and see when the game unlocks for me and why it is set wrong?

Have you reached out to Microsoft Store support yet?