Stuck downloading but was fine before

Got on today after playing yesterday fine, today however on the Microsoft store it wants me to download an 18gb file. tried wsrest and logging in and out. However, it still wants to download the massive file. However, the game is still there it’s just the store wants to download this massive file?

Yeah, I’m getting the same issue.

Was playing last night.

Looks like it’s an update, but 14.34 GB with no information is a bit…

Like I just opened up the Microsoft Store and logged on to see;

Downloading Age of Empires II: Definitive Edition… 0.1 GB of 14.34 GB

Checked my current version: 32708

With a friend who updated his game already: 32875

And trying to find info on this version I’m updating to. 14.34 GB is a lot, for there to be no patch notes. Especially when the game itself was about 18 GB to download.

Like the latest Patch Notes on the forum is 32911.

I know it says that the Steam version is ahead of the Microsoft version, but some insight would be nice. What happened in previous builds and what not.

I did find this. Which addresses 1 bug fix.

Would be nice to see what other fixes / additions have been made.

1 Like

I have the same issue. Yesterday it worked and today it wanted to download the massive “update” of 14.3 GB. Looks like it tries to download the whole game again. I restarted my pc and now it is stuck. Cant start the game and cant download. I dont want to download the game again. my internet is really crap and takes a full day to download. hope they fix this.