Suffering heavily fps drop with my new CPU

So I decided to make an update for my rig, which went from i7-8700k to my brand new i9-11900.
The game got HUGE fps drop afterwards, from 144+fps to only ~40fps @ stone ages with 5 units on the screen.
My specs :
Intel core-i9 11900
40Gb RAM
GTX 1060

I’ve tried with windows 10 and ubuntu, same result for both OS.


This is normal for the game, don’t worry

no this is not, i have at least 144 fps with my old CPU

No help? Dev? Mod? Please

It is perfectly normal for AoE I, you’ve got to stop freaking out about this.

2 Likes

It looks like they don’t know it themselves.

High frame rates aren’t really necessary in RTS games, why don’t these people realise that?

High framerates are more pleasant for the eyes. I agree with you about the game mechanics.

1 Like

the problem is i got high frames on AOE with my OLD 8700 :frowning:
actually, it bugged me and pretty annoying.

This is why you should NOT have gone Intel. That is your problem right there. :wink: :smiley: :smiley:

I dont think the CPU is the problem, I have no problem with any other games.
And I got no problem with my old Intel CPU too.

Lol. It is a joke. :wink: Go AMD. :smiley: :smiley:

:slight_smile: I dont want a glued together CPU bro. and the CPU is NOT the problem since it run other games smoothly