Tampering warning after editing settings

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 96976
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
After switch back from Return of Rome to regular, and then selecting my hotkey profile, unticking idle pointer option and enabling an idle pointer mod (it doesn’t work for RoR so I use the inbuilt one for RoR). I then go back to main menu, and I get pop-up saying something is messing with the running of the game, and then this text pops up at the bottom of right of the screen:

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • Less than 25% of the time / matches I play (RARELY)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Switched from RoR to AoE2
  2. Selected custom hotkeys profile, labeled custom
  3. unticked idle pointer option
  4. enabled ide pointer mod
  5. click okay on warning pop as described above.
  6. Then text in the above screenshot popped up.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
It have nothing else running, so it should say I am tampering and ask me to restart my game.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Hi @MNVICSN
Do you have the same issue if you disable that mod? Are you using any program that could interfere with the game? Like a third party antivirus, overlays…
Thanks for your report :slight_smile:

No overlays, no third party anti-virus, have used the mod many times, was able to play a ranked game after with no issue. It was super random. I feel like something is bugged between RoR and regular switching because I have to keep fixing my hotkeys and sometimes it load up into RoR even though I last played and last time loaded it up into regular. I only just bought the RoR DLC, last Thursday. So I don’t know if the installation of that is potentially an issue?

It might be, try verifying integrity of game files in Steam.

Just ran the verifier, Steam found no issues.

It is possible that by some reason that mod is interfering with the game now, even after disabling it.
I recommend you to try some stuff:

  1. Deleting your user files. For deleting your user files, you should:

a. Make sure that your Steam Cloud is disabled in Steam, AoE2 game, Properties, General.

b. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE.

c. Copy your user folder to a safe place, it has lots of numbers.

d. Delete the original folder

e. Verify your files in Steam, AoE2 game, Properties, Local Files.

f. Open the game again. A new user folder will be created.

If this works, then copy back the files from your old user folder. Those files are in the folder -C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

@MNVICSN
Just disable Windows defender Tempering feature explained in this post: [Fix] A running process may be interfering with the correct operation of AoE2 DE

And that should fix it. There is no security risk when you disable tampering, tampering is there to protect windefender from getting disabled by other programs, also stops 3rd party programs which is in this case “AoE2 DE” from making changes to the system. So yeah just go ahead and disable it forever, I myself have it disabled always.

@Felizon89 Hello beloved developer,
I would like to direct your attention to the reason to why AoE2 DE is tampering with the system files permissions, specifically the mods. AoE2DE_s.exe, at launch post splash-screen, is changing file permissions of files and folders for mods installed in %userprofile%\Games from read only to full permission. Even if I were to strip the mods folder from read and write permissions apparently “AoE2DE_s.exe” is changing them back.

That should be looked into in addition to mods often crashing the game. If any mod is deemed incompatible and may cause a crash make it so to ignore enabling that particular mod.

Thank you

1 Like

last part is a big no. if they change stuff that affects a ton of stuff each patch, it is almost impossible to tell what might be causing the crash without playing, which is a form of troubleshoot tool for modders.

if you don’t even let mod get past on load up then you are asking modders to blind test.

1 Like