Technology State Condition value “Disabled” resets to "Done" (Not Fixed with Update 37650)

Game Version: 101.101.36906.0

  • Build: 4941835
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: MrKirby

:bangbang: AFTER UPDATE 37650 :bangbang::

The Disabled option now does not go invalid (red). But is now set to -1 which still makes it default to Done.


When using the Technology State Condition when selecting the Disabled option, the condition will become ‘unvalid’ (red) and will reset to StateDone .

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Create trigger
  2. Create condition Technology State
  3. Set State to Disabled
  4. Click condition again and see the Tech State reset to Done
1 Like

Just to clarify, this is the scenario editor, right?

Yeah… Those things (ie. triggers, conditions etc.) only appear in the scenario editor. Don’t they? If that’s not the case, my bad. I’ll clarify next time I’ll report a scenario editor related bug.

I just wanted to post here that this is STILL NOT FIXED. I just tested this. It’s such a simple fix. Change so that ‘disabled’ doesn’t represent the -1 value (which makes it default to done). pls pls

This issue has not been fixed with Update 42848 .

This issue has still NOT been fixed with the latest (1.5 month old) Update 47820 .

This particular issue has been fixed. There’s still some other issues with Tech State, Disabled but that’s for another issue.