Test of Strength Masteries Not Completing (not the save bug)

All of the Test of Strength masteries have not been completing. It started at one civilization and now I’m stuck on every Test of Strength mastery at different difficulties. I was able to get the Chinese fully done on 3/29/22 but everything else isn’t working. I play 1v1 skirmishes hoping it’s fixed but it hasn’t been resolved in a month or so now.

  • No I didn’t save and return to the game
  • I have tried different types of victories
  • I have verified installation on Steam
  • I have completely uninstalled and reinstalled the game

Game version: 5.0.12973.0

1 Like

Hey @blazingsunn! I assume “Assize of Arms” completed without issue? Are you able to try to complete “Rally the People?” This obviously wouldn’t normally work, but I’m wondering if this is a UI bug or something else.

You may also just want to contact support with your warnings.log file. They may know something I do not.


after 4 attempts to defeat an easy AI in 1v1 with the Mongols, the game never validates my mastery and therefore blocks me from the following ones.

I did it with the other factions, and the masteries were validated on the score screen.

Could you fix it?

1 Like

Here you go, I will look up the logs and stuff. I wasn’t sure if I would need them since nothing is crashing.

I will contact support today.

Steam ID: 76561198007316075

  • No mods used
  • No VPN used
  • I’m using Avast Free Antivirus

I downloaded the DxDiag but I can’t upload it since I’m a new user. I’m not able to figure out what error logs I need. I found the folder that is in the directions on, https://support.ageofempires.com/hc/en-us/articles/4408793405460-How-to-find-information-for-troubleshooting-with-Support

1 Like

Really appreciated @blazingsunn!

The log you’re looking for should be here:

Every little bit of information you can give really does help. Thanks!

Oops, I sent the wrong thing then. I appreciate it!

Not sure if you ever got a response or a solution, but I’m having the same problem almost nine months later. Can’t complete the French or Ottoman Test of Strength 1 masteries either (the only other ones I’ve tried). Kinda frustrating and makes me not want to even try any other masteries.

1 Like

Same situation here, received the game as a gift on Christmas I have tried the campaign, a couple of skirmishes game and art of war challenges. I have not unlocked a singole mastery, not even the tutorial ones. This is clearly a problem and I am frustrated in such a way that I’m going to play again AoEII instead of enjoying this new game. Microsoft, Relic c’mon fix that bug is unbelievable annoying.

Hey, all! Sorry this one is taking so long. There is a likely fix in the works, but it won’t land the next full update—hopefully the one after.

1 Like