The Kushluk Assassination - Achievment doesn´t work for me

Game Version:

  • Build (hotfix 34793)
  • Platform (Steam)

Issue:

The Kushluk Assassination - Achievment doesn´t work.

I killed Kushluk in time (19:36min), but the achievment did not count it.

Reproduction Steps:

  1. (build up an army)
  2. kill kushluk at 19:36min

I cannot confirm that. I was successful on Friday with this achievement. I played on Standard difficulty and the game was done by the first 5 minutes? I launched my hunt for Kushluk immediately right from the start…no base building :slightly_smiling_face:

i tried again, and the problem is, that the timer is wrong. 19 minutes worked perfectly.

i think it´s because the achievment isn´t triggered with the death of kushluk, it is triggered with winning the mission. and there is a time delay between the death of kushluk and the winingscreen.

i think this still should be solved, because it is really misleading :wink:

1 Like

You are right, I forgot there is a time lag…

1 Like