The site is not allowing me to edit my mod page. Keep getting errors

Anyone else having issues trying to edit their mods? All I’m trying to do is edit my mod from Speech to Textures and add some screenshots to it, but it keeps asking me to either re-verify my mod and / or keeps giving me errors when I’m trying to save changes.

@DodoNotDoDo Do you know what might be giving @Mmac2797 trouble?

A tried to upload a new mod yesterday and happened to me the same

I’m having the same trouble.
Uploaded 2 taunt mods in game, forgot to upload an icon for one and both seemed to be tagged with sound but not taunt, can’t update either.
Also having some strange issues in the mod manager, both are coming up twice in the installed mods section and in the my mods section I see a version of both it says is unpublished and one has a copy that says published but 0 files and a larger file size than the other.

This should be fixed now. You’ll need to log off the web site and log back in.

Now is worse, Type button is not showing options and Tags is missing

Sorry, posted too soon. Now it’s fixed.


Managed to change the mod image and add a tag successfully, but I can’t change the type from artificial intelligence to taunt. I also tried to format one of the descriptions but that didnt seem to work.
Also, when I click My Mods on the site it gives me no results, but they show up as the only things in my installed mods when I do have a couple others installed.

Mod page for me is empty, are there any submissions yet?

@blazel420toast These additional items should be fixed. For My Mods, be sure you’re selecting the appropriate game.

@Legitti If you’re not seeing any mods, try logging off the web site and log back on.


7 of course! Thanks very much for all your help :3

Had trouble logging in a hour ago, but everything is working fine now on my end.

trying to upload a new mod getting "Error submitting mod! Please verify your data and try again.” how can i fix this? it does not tell me what is wrong.