Trying to open Essence Editor


Hello, i just realized the mod things was extended to march 25

i opened it the first time and it worked and from then on its been giving me this message.

not sure what to do

This crash will happen when the Editor is launched with an incorrect working directory. If you were given a key for the Content Editor, please contact help via that pathway. If you weren’t, safest bet is to wait for the official release. However, you are welcome to contact support. They may be able to provide you with tips that I can’t. Thanks!

ok thank you i did not get a key , that makes alot more sense. i cant wait for the official release!!!

I have the official beta and I still get this message. Any ideas?

@PredDave57 I know a guy that might be able to help!

Hey @Licidy! Got any tips on solving this one?

Cool. I hope so because I have gone through all the steps multiple times!

Hello @PredDave57 ,

Could you send us a copy of your Warning Log, Essence Editor Log, and Session Data files? They should be under Documents/My Games/Age of Empires IV. Use this form to submit them. Please include a link to this forum post in your submission, so that Customer Service has a reference point.

After sending in your logs, please see if these steps help to alleviate the issue:

  1. If you see “Age of Empires Beta” or “Age of Empires Test” folders in your My Games folder, please delete them.
  2. Make sure you are launching the Content Editor from within your Steam library (or its MS Store app). Do not launch from the EXE file directly. Steps for this can be found here.
  3. If the above steps do not resolve the issue, please try deleting the Age of Empires folder from your My Games folder, and then launch the Content Editor again. If the error persists, it should generate new error logs. Please send in these newly created error logs using the same steps as above.

Hope this helps! Deeper troubleshooting than this will have to be done via email as we may need to ask about personal information found in your warning logs.

Okay, will work on this.
Thanks!

I did all of the above and relaunched the Editor but to no avail.

For me it was windows security blocking the EssenceEditor.exe

Specifically it was controlled folder access.

You can see if you have it on by typing ‘controlled folder access’ in Windows Search, opening it and checking if it is toggled on.

If it is, you can check to see if the EssenceEditor.exe was being blocked by looking at ‘Block History’, but for some reason it wasn’t showing up in my history.

Still, I did see the Windows security message pop up every time I tried to open the content editor, so I knew it had to be it.

I clicked on ‘Allow an app through Controlled folder access’

clicked ‘Yes’ to allow

Then clicked the ‘+ Add an allowed app’

clicked ‘Browse all apps’ from the dropdown

Then navigated toC:\Program Files (x86)\Steam\steamapps\common\Age of Empires IV

scrolled down until I found the EssenceEditor and clicked ‘open’

This added it to my allowed apps list and then the content editor opened just fine after that.

Hope this helps someone.

1 Like