UHD addon will no longer install from Microsoft Store

Game Version:

  • Build (33164)
  • Platform (Microsoft Store)


Installed fine originally on older patches. Had to completely remove the game due to suddenly not launching at all, which started happening after 33164 update. Reinstalled game successfully but cannot install the UHD addon. Store pretends to start downloading, finishes instantly, says “Installed”, but refresh the page and of course it is not installed, and cannot be made to install.

All manner of Microsoft Store resets, repairs, command line re-registering, cache resetting via registry, have not made it work again, and I want to be able to zoom in on my 4k display again.

It is just one issue after another with the Microsoft Store version.

Reproduction Steps:

  1. Install 33164 build from Microsoft Store
  2. Try to install UHD addon

Not one of the known fixes for Store issues has worked. Have also tried logging out of the store, and removing the Game Services package is another known fix for things, but no dice on this one. Next is reinstalling Windows altogether … will be a right pain if that doesn’t do it lol.

Did you also try this trick?

Thanks, yeah I tried that, but it still won’t install. Now there has even been a stealth update to 33315 that the homepage doesn’t even mention, and it still won’t work. Tough times lol.

Glad I’m not the only one experiencing this. Just got off with support with no fix either :frowning:

Kinda hope they fix this. Don’t want to go through Steam honestly but had no problems there as an insider from using the Mod. It just stays on “Pending” for me. Kind of a shame :confused:

PS I too tried to reinstall Windows 10 with the November 2019 update. Tried to reinstall the game too. Just about everything. If you haven’t done it already, save you some time.

Woo. Bug buddies :persevere:

Thanks for the heads up. Now to get their attention! Hard work over the oh so many known issues already.

I like using the built in store and even uninstalled steam lately, but boy do they make it difficult!

OK So I kind of figured it out after a while of fiddling. Here are the steps I took:

-First make sure the mod and the game are both fully downloaded.
-Launch AOE2 DE. Go to settings and turn the settings up to Ultra.
-Knock out the first bit of the William Wallace campaign (since its just about the shortest one).
-Try and relaunch a different campaign. If it doesn’t enable the mod automatically, try and restart the game and try again.

This worked for me. YMMV. I have a hunch the mod has a prerequisite of sorts that before it launches, it makes sure the game works on highest setting or something, but idk.