Unable to destroy stone walls?

I’m not entirely sure if it is a bug, or the devs have chosen to leave this out, but I am unable to destroy my stone walls and gates when placed. Anyone else experiencing this or knows if this is purpose?

I haven’t honestly tried it out myself. I have built many walls but never deleted them. :thinking:
I reckon there should be a delete button to destroy the walls. Have you tried clicking on the wall and seeing if the toolbar has a skull on it?

You can’t destroy buildings if a enemy is close

1 Like

I think it’s to prevent you from deleting walls with the enemy on them. I don’t think that would matter, because the wall collapsing does nothing to the units on them.

The enemy can also unload units onto your wall with siege towers and essentially turn your own walls against you. I have not seen this in a multiplayer game yet, as most people will just punch a hole in the wall and rush through instead.

Thanks guys, that was indeed the case! Thanks for clearing that up though :slight_smile:

You would be able to delete their DMG bonus this way.

Or to instantly create a flanking opportunity for you.