Unable to find Multiplayer lobbies or join friends


I’m unable to find any multiplayer lobbies or create a lobby. I can receive friend invites, but when I try to join them it just doesn’t work. My friends see me in the lobby for a couple of seconds before I get disconnected… I only see a loading screen.

To give you some context.

  • I was able to play with friends before.
  • I recently moved to another country with a different router.
  • I tried port forwarding, but not sure if done correctly.
  • I disabled firewall
  • I checked ipv4 settings in windows
  • Tried connecting to a VPN

I honestly don’t know what the problem is. If this is a an issue on my side or that of the game. Since it was working before it’s a bit frustrating at this point.

If this is truly a problem on my end or that of the game I would love to know. If this is a router thing I would love to know what to write down in the port forwarding.



So for the creation of the lobby I’m able to create a lobby if I remove the lobbies name. I can then rename my lobby after I created it. Still my friends are not able to join me. Ranked seem to be working for at least a minute, haven’t tried to play it longer since I don’'t play ranked matches.

I now also receive this message when entering the multiplayer lobby menu.

So I have the game on Steam and now have it on XBOX (PC) as well, because I have the pass. I installed the XBOX version and I’'m getting crashes when the game starts playing the intro animations. I honestly don’t know anymore what to do.

I just updated to the latest Windows update in order to get the XBOX game pass going. I have a high end PC for doing video editing or 3D modelling so highly doubt that would be the problem here.

5 So with XBOX version I’m running into this issue.

Hello Driekus8124, welcome to the forums!

Just log off from your Microsoft Account at the main menu and you should be able to browse, join and create lobbies again.