Unable to play with a friend on the same network?


Me and my friend have both purchased AoE2:DE via the Microsoft Store. We both have the latest update. Yesterday we tried to play with each other via the Lobby browser. One of us hosted the game and tried to invite the other via the player search, we saw each other online but the “invite” button was grey hence innactive.

I have a feeling that it might have something to do with the fact that we were both on the same internet network, or could it be something else? Playing online otherwise is not an issue.

Thank you,

1 Like

I had the same problem. Try to invite your college clicking on to Invite from Xbox Live (i dont know if this is exactly the button since i have the spanish version). Once there you may be able to invite them. Of course you need to have your college account added as friend on xboxlive account.
Hope this helps. It worked from me on the same network…but now Im having huge lag issues.

Thanks buddy, it actually helped :slight_smile: But it should not be this difficult to connect in 2020 :slight_smile:


Hey there! If there’s still trouble connecting then it can also be helpful go to your firewall settings and allow incoming communication on TCP Port 8888 , as well as Port 3478 (UDP & TCP) and Port 5222 (UDP & TCP).

I hope this helps!