Unable to use custom terrain types in terrainlayout scripts on the PUP

Really excited to see the option to make custom terrain types finally in the editor, but struggling to get them to work properly.

I’ve tried creating a new terrain type by cloning an existing one and giving it a new name, but whenever I try to use it in the lua, map gen fills the tiles with random tiles as if set to tt_none.

-- Fill the entire map with the custom terrain type
for row = 1, gridSize do
	for col = 1, gridSize do
		terrainLayoutResult[row][col].terrainType = tt_my_test

I can get one terrain type to work by setting it as the only weighted_terrain_type in the map_gen_layout and setting tiles to tt_none, so I know the terrain type self is fine. It just doesn’t seem to create a variable referencing it.

I also tried burning it

but if I burn it with the alias data the mod doesn’t load and gives the following error:

(I) [00:33:39.427] [000002212]: MOD -- Error loading mod pack 'cff0f1cfe884403f9cdf1f44206f4af6': tt_my_test.rgd not permitted.
(I) [00:33:39.427] [000002212]: MOD -- Error loading mod pack 'C:\Users\Sammie~\Documents\My Games\Age of Empires IV - Test\mods\extension\local\Tttest\tttest.sga': invalid file structure.

If I burn it to attrib it builds the same as if I don’t burn it at all.