Units Freezing when moving. Video included

Units freezes in game. The game itself is not freezing since I can still move the camera while the units are freezing. It is super annoying and I dont know what to do. I tried updating GPU drivers, updating bios and verifying steam files.

I made a video with OBS, so you can see:

I have a Rtx 3070 and 5800x. 32Gb of Ram. Not overclock at all (only XMP on Ram, it is DDR4). Game is installed in SSD. I play at 1080p in high, but tried setting the graphics in low and the units still freezes. I checked in afterburner my GPU and CPU and it is not reaching even 50%.
Windows 10 64bits. Not any mod installed

Can anyone help me? I made a research and found nothing

UPDATE:

I FOUND THE PROBLEM!!

Playing with Mongols, these units freezes happen each time I break a building. You can see it clearly in this video:

It seems to be a bug. I found more people reporting this, but it is not fixed yet:

h ttps://forums.ageofempires.com/t/gameplay-freezes-when-i-play-mongol-and-destroy-enemy-buildings/189062
h ttps://www.reddit.com/r/aoe4/comments/qm5y0r/aoe4_screen_freeezes_when_building_get_demolished/

Anyone else have this problem??