Units garrisoned inside allies' buildings can't be ungarrisoned by the unit owner

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #:71094 ######
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


After the last update #71094, sometimes units garrisoned inside allies’ buildings can’t be ungarrisoned by the unit owner. Only the owner of the building can ungarrison them.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 25% of the time / matches I play (SOMETIMES)

:arrow_forward: ############ STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Garrison your units inside an ally building
  2. Try to ungarrison them, but can’t
  3. The ally, owner of the building, can

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

You should be able to ungarrison your own units on an ally building

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

Not relevant

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

A recorded game wouldn’t help in this case.


We are already tracking this issue.
Thanks for your report!


Me, too. This happens in the lastest version.

1 Like

This bug is listed as fixed, but was NOT fixed in the last Update 73855. The bug still happening on the same way.

“* Fixed an issue where units garrisoned in allied buildings could not be ungarrisoned.”

I couldn’t reproduce in 73855, there is an issue with the hotkey tho, but the units can be ungarrisoned.
Thanks for reporting it :slight_smile:

Did you test in multiplayer? This bug doesn’t ocurr in single player mode.

Yes, we tested it in a few multiplayer games and different buildings. Do you think this could happen for an specific civilization or under certain specific circumstances?

I successfully ungarrisoned my units from a friends building multiple times since the update !

1 Like

i’m not sure, but i will update here if i can map it

1 Like

For me it’s still bugged in general multiplayer, with all buildings and civs.
I used to ungarrison in the following way: I clicked an ally building, then shift clicked on the icon of my garrisoned units. It still doesnt work now.

Is there another way to ungarrison from an ally building?


You can ungarrison the units by clicking on the Ungarrison icon in the building UI.

I tested both ways, so the bug remains when you click the units to ungarrison and is solved only when you click the ungarrison icon in the building UI.

I couldn’t reproduce this way, it works when you click the units and when you use shift+click. Do you have custom hotkeys for ungarrison?

Both don’t work for me, no hotkey involved, I only click in the units garrisoned, with or without shift, can’t ungarrison. I can only ungarrison if i click the ungarrison icon.

This is strange, can you try verifying files in Steam?

well, i had a clean install of the game recently and the bug was the same on the old computer. Also there are many other ppl having the same bug, as you can see other posted here on this same thread. So i don’t think it’s about personal files.

Hi @AirmailAttic719
I could repro this issue by hosting a game without cheats enabled. Shift+click didn’t work for me when garrisoning villagers into ally buildings, normal click worked tho. If you have any more info to add, please add it here :slight_smile:
Thanks for your report, we’re gonna keep investigating this issue!

1 Like