Various gather point issues

Game Version:

  • Build: 4819260
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Vasemmasti

Issue:

Gather points don’t seem to function as expected. Sometimes I’ll find my villagers running off to the opposite side of the map after spawning, and then continuing to do so after I set new gather points on every single TC. At other times, I will place a gather point flag onto the military building creating units, with the expectation that they will stay garrisoned. Instead, they spawn next to the buildings.

Reproduction Steps:

Can’t really offer anything here because it seems to just happen randomly, yet often enough that I’m convinced something is wrong (including that I never had these issues on voobly)

Hey there! Thanks for the report! I don’t suppose you have a video or replay file that highlights the issue you’re seeing? Additionally, does this only happen on certain maps / game modes, or everywhere? Are there any steps you can provide that will help us narrow down the issue to its root?

Let me know, and thanks again for keeping us informed!

Happens to me as well, randomly my TC (sometimes monasteries too) put the gathering points in some weird map areas…

1 Like

I haven’t noticed a pattern in terms of game modes or maps. Some of the issues I’m seeing do seem to be related to the gather point not registering an update. Having a forward gather point and then changing it to a more defensive position doesn’t seem to register consistently (so the units go to an old gather point). I play almost exclusively multiplayer, ranked, unranked, 1v1, and team game.

It doesn’t seem like I can upload replays directly to this forum, so here is a google drive link.
https://drive.google.com/open?id=1M1J-4HMFnSmeKDyqOoNPdW7D3c-rrzgF
One of the games is an unranked Arabia 4v4 where I am Tatars. In this game I saw new villagers tasked to a woodline at the front of my base inexplicably run to the other side of my walls. I also saw villagers run to my forward siege workshop after numerous attempts to reset TC gather points to resources within my walls-

The other game is an older 1v1 ranked Four Lakes game. In that, I had stable gather points close to the opponent’s economy in late castle age. Then after my push failed, I tried to select all stables and set a new gather points, but new knights continued running into the enemy base.

1 Like

Yeah it seems really bad this patch.

It happens to me as well, many times. I even changed like 3 or 4 times and vills or units just keep going to a different place. Or in some cases to a previous gather point.

I added another replay where this happened to the folder, from the current patch.
https://drive.google.com/drive/u/0/folders/1M1J-4HMFnSmeKDyqOoNPdW7D3c-rrzgF
Kept happening in the castle age. My villagers kept walking into and garrisoning into my castle despite repeatedly resetting the gather points to resources. I get the feeling that what is happening is that it’s just using an old gather point, because I gather pointed the TC onto the castle foundation earlier to get my vills to build it.

Hello everyone! I’m afraid our team has been unable to reproduce this issue internally. If you chance across it again in the latest build (39515), it would be extremely helpful if you provide the following files:

  • A replay or recorded game file.
  • Play-by-play notes as to when and where the issue takes place.

Thanks for your help!

Thank you for this! I’ve attached it to the ticket for investigation! If you see the issue in the latest update, please continue to attach these with details as to when the issue occurs.

Try using a select all hotkey to select all buildings of the same type (ctrl+alt+something by default I think) and then try to set a common gather point. In my experience this fails a decent chunk of the time and causes units to spawn with a default gather point rather than where the gather point was set.

Here’s a replay with weird stuff going on with the gather points around 10:00-12:30. I used TC to send vils to my 2nd lumber camp and was 99.5% sure the gather point was set there, but they went to a straggler tree (the gp looks set on a straggler tree in the replay though). I tried again just a bit later and they went, but the gather point in the replay looks like it was set to some random ground near the lumber camp (which I don’t think I ever did).

Still a common issue for me, very annoying.