Vsync messed up for amd graphic users

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.47820.0 6624001
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

On default radeon settings the game still limits the fps to the display refresh rate on vsync disabled, both in game and the in the radeon software.
If this is the case, the game feels choppy.

Solution: Turn on Radeon Enhanced Sync in the Radeon software in the Gaming tab.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Use a FreeSync panel
  2. Install the latest AMD Radeon Pro software (21.Q1.2)
  3. Use standard graphics settings as preset under Settings/Graphics
  4. Make sure FreeSync is enabled under Settings/Display
  5. Install Fraps to show the actual framerate. The ingame fps counter is misleading. The hotkeys for recording and screenshots are not needed and should be disabled. As alternative the Radeon overlay can also be used.
  6. Start a single player game. Fraps shows the display refresh rate, despite the ingame fps counter showing 200+ fps. The game runs choppy.
  7. While the match is running, go to Gaming in the Radeon software and enable Radeon Enhanced Sync. The game will run at higher fps, and Fraps will show the same fps rate as the ingame counter. The game runs smooth. If this does not work, restart the game and start a new match, while keeping the Enhanced Sync option enabled all the time.
    If Enhanced Sync is disabled again, the game will remain running smooth.
    In order the get back to the bad state, the game has to be quit to desktop and restarted.

Notes: My Card is RX470. I always use FreeSync, so I have not tested it with FreeSync disabled. FreeSync is and should be the system default anyway.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The game should run smooth out of the box on default driver settings (I consider enabling Radeon Enhanced Sync to be a workaround).
The fps should not be capped to the display refresh rate.
The ingame fps counter should show the same fps like Fraps.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

The above is the state out of the box/clean driver and game installtion.
The below shows the state after enabling Radeon Enhanced Sync.

The setting can be found in the driver utility, see below.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

Thank you so much for the post! Can replicate same problems, game is unplayable with AMD on some monitors. This post is accurate and helpful.

Workaround works for me if DE stays the same (heh) and the monitor is willing to oblige with FreeSync.

Otherwise, as the Devs here at AoE2 say; just buy more stuff, folks!

Hey @UnfamousScout
Thanks for the report we are now tracking the issue and looking into what can be done.
Have a nice day!

1 Like

Did you ever get a new graphics card that works? I’ve got a Radeon RX580 (similar to your RX470 I’d assume) and this issue isn’t going anywhere so I’ve got to buy a new graphics card for the game (intel Core i5 i5-8400).

Any replacement graphics card brand suggestions that Age2DE supports would be great!

Only solution I know is to all

  1. use a FreeSync panel
  2. use RX470
  3. use most recent driver
  4. use driver defaults, but turn on enhanced sync for age 2 de
  5. turn off vsync in the game

I don’t know if that works with other AMD cards, i can’t test right now.

1 Like

I add a reply because apparently the thing is fixed.
Not only that, but I noticed that if you use Freesync and activate Enhanced Sync, as soon as you launch the game, windows desktop manager (dwm.exe) lags the whole system and it’s pretty noticeable if you have a high refresh monitor as I do (165hz).
Disabling the Freesync just for the game doesn’t work, I tried.
Bumped this thread because imho this is important and I was getting insane trying to fix the laggy windows desktop UI.

TL,DR: activating Enhanced Sync is no longer needed. Tested with fraps.
Activate Freesync, disable V-sync, set the ingame fps limiter and enjoy the game.

bro i have the same recently. like if i drag a window the animation has like like 5 fps.
what is this?

A bad interaction between freesync and enhanced Sync, at least on my PC it was that. Disable enhanced Sync if you had it on. Disable vsync and use the ingame fps limiter. This worked for me.

I have enhanced sync off now.
What’s bascially happening is:

  • Sometimes on match found, even before I am in the loading screen, my Windows UI becomes laggy (slow response time, doesnt drag smoothly) and also my webbrowser (webapps, web video players).
  • If i close the game it persists, need to reboot to get rid of it
  • It doesnt happen every match.
  • I never have it, if I am not using Age 2 DE.

Bro what is this? -.-*
This is driving me crazy.
Have to reboot my computer very often now.
I swear by god every patch there is new crazy stuff with the app.

I’ve sent you a message with some tips.
Aoe2 was the only program that gave me those problems too.

Is there already a bug report with the dwm.exe issue?
If not I may open one later.
How did you find out/profile that dwm.exe is the issue?

(update) The issue continued on my AMD Radeon RX580.

The problem caused the game to be unplayable on my monitor setup, which could handle any other game just fine.

I purchased a $300 NVIDIA graphics card. My NVIDIA graphics card handles Age of Empires 2 DE no problem. I attempted every other fix on this forum before the graphics card replacement. This is the only fix for the issue I have found that I can confirm works.

1 Like

This doesn’t work with newly installed latest Adrenaline Driver

I tried with RX580, Freesync on, VSync Disabled and in game limiter at 60 to be safe.

Original frame issue persists unfixed with current software

For anyone still looking for fixes I suggest turning off VPR and other info in the replies of the linked forum