White Screen with sounds

#1

After I get past the steam menu with Play, Workshop, AOE Website, and Achievement on the left hand side, my screen goes white. The cursor becomes the AOE Spear pointer/the hand and sounds/music are playing. I am running Directx 12 and windows 10 on a laptop (not very tech savvy). The game has played before but not for a while now.

Have already reinstalled the game and steam however I got the same results.

Please help !

#2

You could try pressing Alt + Enter twice first and see what happens.

1 Like
#3

Unfortunately that didn’t help it, it simply popped from full screen into a smaller window, still completely white with the cursor changing. Any more ideas?

Thank you for replying though PSC70 !

#4

Well, it’s not stuck at least. Go to device management and rightclick your graphics adapter and choose update driver and then search automatically for driver updates online. You might want check more devices for available driver updates too. After that reboot and try again.

#5

If you have not already, make sure you’ve downloaded the latest version of DirectX 9.0c:

https://www.microsoft.com/en-us/download/details.aspx?id=34429

Even though you’re running DirectX 12, the patches are not all-inclusive of earlier versions, which means you’ll need to download and update DirectX 9.0c if you haven’t in the past. Reinstalling those may help with your issue if you’ve already tried grabbing the latest Windows Updates and graphics card drivers.

Good luck! I hope this helps!

#6

To PCS70 & GMEvangelos,

Thank you for your replies. I have attempted both of what you have suggested however neither have worked. My drivers are all up to date and I am unable to download DirectX 9.0c as I am running windows 10 and it does not allow for it to be installed.

I have also done a complete clean of my computer, deleting all files relating to steam and age of empires (searching AOE, AOE_II and every configuration as such) as well as uninstalling steam and AOE2. I then reinstalled but to no change.

I can screenshot while on the white screen and when I look at the photos it displays the graphics as if they were normal in the screencaps.

Still very much in need of help.

#7

Did you launch the Steam client program elevated as administrator before installing and running the game for the first time?

You will have to launch the Steam client elevated (as administrator) again whenever there is a update for AOE 2 HD through steam.

In order to run Steam client as administrator you must first close Steam client and then rightclick the Steam icon in the start menu (or on your desktop if available), choose more and select run as administrator.

#8

That is actually very strange. So it looks like some kind of graphical overlay problem to me now.

Could you post your dxdiag report here?

Just search for dxdiag with Cortana search glass.