Windows Store Install Error Code: 0x8007001F

Last friday I received an invite for the multiplayer beta. I had to update windows to 1903 and downloaded the insider-hub. The link to the store works and the “install”-button is blue. It asks for the install location, says “downloading…” for a while but then terminates with error code 0x8007001F. “An unexpected error occured”. The download started successful once in the beginning but my internet connection was separated during the download.

I have tried stopping the download and starting it again, rebooting multiple times, deleting store’s cache, running dism.exe, wsreset, cleaning up temporary files on the harddisk, checkdisk, installing on a different harddrive… no success so far.

The microsoft account is correct in the store, there is no other account registered on my PC and using another user account on the PC did not help, too.

As I am slowly running out of options… any ideas??

Thanks!

Upgraded Windows 10 again using the media creation tool. There is no longer an error code, just a generic error message. Other free apps and updates are installing properly. Anyone else experiencing those problems?

According to that screen shot, it shows you need “Administrator approval required.” Have you gone to properties to make it run as administrator - always?

How would I do that? I can not find an option to launch the store app as administrator. The game is not installed yet

I would click ‘….’ button and check for all other updates first. As it states that you own the game already it might be listed in your library already and you could try to install from there. Also sign out and sign in to MS store app could do the trick.

Btw. There should be a specific beta forum section only for beta participants where you as per NDA have to ask questions like this.

At least I’m happy to see that the MS store beta of AOE II DE has begun.

The “…” drop down menu includes only one item called “install on my devices” and does not do anything. All other updates are finished. The game does not appear in my library. Logging in and out in the store or insider hub app did not help. Tried downloading an hour ago and encountered the same error.

I don’t think discussing such a store related problem is prohibited by the NDA. Nevertheless I tried to move the thread to a more specific support forum. It looks like I am not allowed to move my thread. Would be happy to see an admin do that.

Don’t worry @RadiatingBlade will come to our rescue for that one.

Do you sign in using a MS connect login account or dedicated local administrator account?

If the latter is not the case I would certainly try it by enabling the built-in local administrator account or just add one new dedicated administrator account, sign in trough that account and follow the instruction again (except for the upgrade to 1903).

Sometimes the user’s profile just got damaged or not migrated correctly.

I like keeping things local on my PC, therefore the two accounts I have tried it with so far are an admistrator and a normal account both local on the computer. A few minutes ago I created a new MS connected user with my closed beta microsoft account.

The store asked for administrator privileges, I was able to select the target harddisk and it downloaded 65KB. Then it stopped for a short time and terminated the download. This time with another error: “Code: 0x80040154”. After a reboot I’m encoutering the same error shown in the screenshot above, “try again later”… :confused:

Just noticed a notification from the store in the notification center. The download progress indicated 4%. But it was not downloading anymore, the notification disappeared right after I clicked it.

Hey there,

Can you please try the following troubleshoot steps?

  • Reset the Windows Store App. You can find directions for that HERE.

  • Run the Windows Store App troubleshooter. You can find directions HERE.

  • Use the System File Checker to repair Windows Store. Directions on that tool can be found HERE.

  • Use Powershell to Repair or Reinstall the Windows Store app. You can find directions HERE.

If these steps do not resolve your issue with the Windows Store app, then you may need to reach out to Windows Support or Windows Store Support for further troubleshooting. Please let us know if you do and any answers you find so that we can refine our troubleshooting process. Thanks!

  • After resetting the Windows Store app I am still experiencing the same problem.

  • Windows Store Apps troubleshoot identified one problem: “The location where temporary Internet files are stored has changed”. It fixed that but still no success.

  • DISM finishes without any errors, sfc says “Windows Resource Protection did not find any integrity violations.”. The problem in the store remains unchanged.

  • Reinstalling the store changed nothing.

Today I had some time and did further research. I created a new user again and documented every step carefully. The beta download starts only one time per user account. It fails at “downloading… 4%” with error code 0x80040154. Once the first download is terminated the undefined “Try again later” error occurs everytime ~ 2s after pressing “Install”.

Triggering the download of the beta actually causes two installs. An update of the Game Services app and the game itself. The Game Services app gets stuck at “installing… 90%”. Resuming both downloads does not work and fails with error code 0x80004004.

Fun part: Just for the sake of trying I used another PC, signed in there and started the download. It failed EXACTLY the same way like my PC, one download stuck at 4%, the other 90%. After terminating this I am getting an error “Try again later”. The error codes are the same.

Other apps in the store are downloading properly. It looks to me like there is an error in the license verification / identification of my PC. Is it possible that the one first unsuccessful download sort of “stamped” my beta license as used on the server and therefore prevents me from downloading? (The first time it downloaded a few GB before my internet connection was separated). I doubt that Windows Support is able to help me on that one, nevertheless I will ask them for help. I will keep you up to date.

@Tomatoes96 - Thank you for the update and trying these steps! From the details it sounds like the Windows Store is getting stuck on updating the Gaming Services extension, which the game needs to have updated before it can finish an install - since that service is getting stuck downloading it does look to be an issue between your machine and the Windows Store. Please keep us posted on what answer you discover as it will help us refine our troubleshooting process.

This should not make a difference. The beta license is tied to your Microsoft account & Xbox Live profile. The Xbox Insider Hub serves as a secondary verification and directs you to the beta version of the product which is normally hidden on the store. So long as you are signed-in to the correct Microsoft account on both the Xbox Insider Hub and the Windows Store, you should be able to download or re-download as needed.

A quick update: Windows support was unable to help. The agents at the chat support kept saying that they feel really sorry about my issue but always had an excuse to send me to another agent “specialized” for my issue. One guy told me betas are there to fail and have a lot of issues, especially when downloading from the store. Some other agent was sure I would get help by searching reddit.com and even sent me an email afterwards with that suggestion. I am still kind of laughing about that. Searched reddit with no success whatsoever.

Unfortunately the issue is persistant with a third PC I tried it on, this time not a dell. I was able to download & launch the game in a hyper-v virtual machine running a fresh windows install though. One thing I noted is that the version of Gaming Services is the same on my PC and the emulated machine with the working game. Maybe the update of Gaming Services fails because of this?

Maybe fully clearing your windows update cache can help you to get MS store downloading again.

Launch command prompt as administrator and type the following:
net stop wuauserv
net stop bits
if exist %windir%\SoftwareDistribution.old rd /s /q %windir%\SoftwareDistribution.old
ren %windir%\SoftwareDistribution %windir%\SoftwareDistribution.old
shutdown -r

After reboot sign in and first run all Windows updates. Thereafter proceed with MS store and download all available updates first and then proceed with install of AOE.

CMD responds with “The syntax of the command is incorrect.” on that one. Renamed the SoftwareDistribution folder manually.

It did not resolve the issue. Since it looks like I am the only one having those issues and it affects three of my configured PCs but worked fine in a clean windows installation, I guess it is my configuration blocking the download. All three PCs run the same antivirus (avira) and the same firewall (zonealarm). I checked the logs there and the configuration, even turned them completely off for a short time to try the download. It did not help. Maybe I have to uninstall the entire security software in order to download this game…

Ah, good’ol Zonealarm. That might be the case then indeed.

Also sometimes the problem is caused by something that’s broken in the local user’s profile. Especially if you sign on with MS connected accounts. What you could try is to create a fresh new local user account and then reconnect that one with your MS account or removal of all local account except the local administrator (after back-up data) and add the MS account(s) again as additional user. A fresh install also recreates the local user profiles. You could also test further by installing Avira and ZA on the freshly installed machine.

Good luck on your technical quest and challenge.

The second parameter should not have %windir%\ in front, my bad. :wink:

The error occurs whenever ZoneAlarm is installed on the PC. Deactivating did not help, at least not in my case.
To get it up and running I backed ZoneAlarm settings up under ZoneAlarm > Tools > Settings, uninstalled ZoneAlarm, did a reboot, installed AoE 2 DE and the DLC, installed ZoneAlarm again and restored settings. Now the game is running. I’ll report the issue and work together with ZoneAlarm in order to fix this problem.

There are significant performance issues on my machine, even though it exceeds the suggested system requirements. I tested those issues without ZoneAlarm. Since that is not related to the posted issue, I will create another thread.
Thank you for your assistance! :slight_smile:

1 Like

Well, my invite already told me I could expect problems due to my older hardware, but I still manage to benchmark at around 17 fps. And a lot of other processes running in the background. Yeah, it’s time for some new tools. Yet, it’s easy to a make a game for the few, but for the developers the challenge will be to make this one work for the many as possible. Bur I’m impressed with what they have come up with so far and all the effort they put in in at least trying to make it run on a broad range of devices.