Zhondu Battle can't be launch


After the video, the loading bar go to 100%. But the “Play” buton never appairs.

The game doesn’t freeze, it just stay like that. The loading bar still animated ### ##### at 100%…

I saw other topics where some have reinstall the game and erase there data with no result. The battle still unaccessable.

(As am here… where does the exploration button and the Rally Bell from older AoE go ??? It fells like a regretion … )

Sorry you’re experiencing this @uebloak! Best thing to do here would be to try play the specific mission that won’t load. Once it fails, then please contact support with your DxDiag and warnings.log file.

Trouble solve. Thank you for your reply.

I just had to wait more than 10 minutes with a fully loaded bar to see the start button apair …

I have had a reply from the support telling me some details. I’ll try to see if it works better after that.

(I finaly find what replace the rally bell … :smiley: Still no signe of the auto exploration button for the scout units and the trampling option for cavalry. It just seams like they have change the game engin bases since AoE 3 …)

Some new stuff are great. So… (But I just hate the kind of smog all over the map… Anyway, it still a classic, I run it on a laptop… and AoE III engin was so perfect…)