Achievement "Protector of the Realm" from Jadwiga 2 (Star of the Poles) doesn't unlock

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 51737
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

Achievement “Protector of the Realm” from Jadwiga 2 (Star of the Poles) doesn’t unlock

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Build castles in each of the 3 neutral towns (grey, purple & orange) before 25 minutes have elapsed
  2. Win the scenario
  3. Achievement doesn’t unlock

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Achievement should unlock.

4 Likes

Same thing happened to me as well. Currently it looks like at least these 3 achievements are bugged in the DLC:

  • Protector of the Realm
  • No Quarter
  • Malevolent Marauder
2 Likes

I have the same problem with two achievements, I’ve done “No quarter” achievement. I have all the achievements less the others named.

Thank you for your reports, we are now aware of the issue! :slight_smile:

4 Likes

Same here, with the problem, but glad you lads are aware

1 Like

Do the other 3 of the 2 campaigns unlock?

It’s weird because xbox unlocks this achievement for me, but not steam. I wonder when the bug is fixed. Do I get the achievement automatically or I have to do the scenario again?

The three Algirdas and Kestutis achievements unlocked to me. And so did “No Baggage” and “No Quarter”. But “Protector of the Realm” and “Malevolent Marauder” failed to unlock. I still haven’t tried the remaining two achievements.

For “No Quarter” achiev, the way to obtain it is just to ignore the secondary object to meet the merc company, Nicholas will join in the final battle along with Ulrich, you’ll kill both and get the achiev (care to kill them before to eliminate the major part of the troops otherwise won’t pop, so focus them with your army).
I tried killing Nicholas in the first part of the scenario before he fled, I killed him but no achiev at the end, try the tact above instead, it works.

Hope this helps

“Protector of the realm” and “Malevolent Marauder” are bugged instead

Bye

Yes, can confirm that “No Quarter” achievement works with the above method.
“Protector of the Realm” and “Malevolent Marauder” are still bugged.

Both Protector of the realm and Malevolent Marauder unlocked on the Xbox but not on Steam.

Greetings dear Dev.
There is also an issue with the Historical Battle “Kyoto (1582)”. I won the mission multiple times by now but it never says that i have completed it (There is also no checkmark). For that reason i can’t get the achievement “Battle Beast” where you have to complete all Historical Battles in single player.
I have as well problems unlocking the “Star of the Poles” achievement.

I logged in today and the achievement popped for me in Steam for Malevolent Marauder! Didn’t even have to replay the campaign (I’m glad because twice was enough for me)!

I was surprised to find both achievements now having 0.1% in Steam world stats. When logging into the game, both achievements pop up without having to replay the games

Wonder how dev fixes this without any updates to the game. I suppose the fix is at server side?

Hi. I got the achievement for Historical Battles before the Dawn of the Dukes update.

Maybe there’s a glitch with this patch.

Suggested for you to create a new thread to report this issue to dev

hi, i got the achievement today, it works now :smiley: