Achievements that doesn't unlock

Hello,

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 7126076
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

List of achievements that doesn’t unlock :
Jadwiga - Protector Of The Realm
Jadwiga - No Quarter
Zizka - Malevolent Marauder

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Lauchn the campaign map
  2. Complete the achievement
  3. Win the campaign
  4. Nothing unlockks

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Achievements should unlock

Comment :

Tried each of those achievements 3 or 4 times.
Tried to change de difficulty, didn’t worked
Tried to verify the integrity of the files on Steam, didn’t worked

I haven’t done the Algirdas and Kestutis campaign but I will update this topic if other achievements don’t work.

Best regards,

1 Like

Same issue with “Protector of the Realm” and “Malevolent Marauder”. Haven’t tried “No Quarter” yet. The Algirdas and Kestutis achievements all worked fine with me.

Edit: “No Quarter” worked with me

Hello everyone! Thank you for your reports, we are now aware of the issue! :slight_smile:

3 Likes

Hi,

Thanks for the reply.
I’d like to add that I just finished the Algirdas and Kestutis campaign > no problems with all its achivements

So the issue concerns only the 3 achievments above (well at least in my case)

Best regards,

1 Like

Just to comment on “No Quarter”: this achievement works, it’s just rather unintuitive how it triggers.

First, you must NOT complete the secondary objective of visiting the Lizard leader in the left corner of the map, he’s one of the enemies whom you need to kill. When you don’t visit him, he shows up as an enemy in the final battle.

Next, you must kill both leaders. If you destroy too much of the gray army before killing its leader, then he’ll run away and flee, and you won’t be able to kill him. You have to focus on killing him quickly once he attacks with his final wave.

3 Likes

“No Quarter” worked for me, but the same issue on the other two.

No Quarter actually works. But I don’t remember how I did it. Maybe T-West’s comment above may help.

The Polish Victory on Steam is another cheevo needed to be fixed. Some ppl get it instantly, some get delayed and the rest do not obtain. So maybe devs might want to check with Steam system or trigger code.

It may be worth mentioning that the Xbox achievements seems fine.

I played on Steam, got the Protector Of The Realm achievements for Xbox account, but it doesn’t unlock on Steam (haven’t tried the other two achievements yet)

1 Like

Another achievement bug:
Hot & Spicy: Don’t let Tabasco die in Montezuma 3 doesn’t unlock if you defeat both opponents (insntead of collecting horses).

Thanks @Dangumai !
I talked with my team about it :slight_smile:

1 Like

Hi all,

There are 2 achievement that I can’t unlock on steam (but I’ve succeeded to unlock on XboxLive).
The 2 achievements:

  1. Baby boomers
  2. Bon voyage

Game Build : 10714595 I guess (the last version)
Game platform : Steam
Operating System : Windows 11

I tried on campaign map, on skirmish, deathmatch, etc.
I Tried to verify the integrity of the files on Steam, didn’t worked
I tried to be online.

Best regards,
flavius1er

1 Like