Age 3 DE no longer loads stringtables from the Mod/Data/Strings/English Folder

:arrow_forward: GAME INFORMATION

  • BUILD #: 6159
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

Age of Empires 3: DE does not load custom stringtabley.xml files if you place them in Mod/Data/Strings/English.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Make a mod where you modify the English stringtable. (Data/Strings/English/stringtabley.xml)
  2. Place it in the mod folder. (C/Users/your username/Games/Age of Empires III DE/User ID/mods/local/modname/data/strings/english
  3. Restart your game to load the mod.
  4. Watch as the game loads default English string tables. (And not your modded one.)

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

The game should load the stringtabley.xml that you’ve placed in Mod/Data/Strings/English.

:arrow_forward: ACTUAL RESULT

:question: What actually happened (what went wrong) because of the issue you’re reporting?

The game loads default string tables. There used to be a workaround for this, where if you loaded a different language in Options/UI, and then loaded English again, it worked, but this fix no longer works.

:arrow_forward: SOLUTION??

You have to place your mod in another language’s folder. If you want to make your mod for an English audience, you still can, however, you will have to take your modified English stringtables and place them in another language’s folder, such as Data/Strings/French. You will then have to select French as your language from the main menu. The game will then load your custom stringtables, and if your custom stringtables are in English, the text will be in English in game.

A downside to this however, is that if you want your game to be in your own language, you will have to copy EVERY stringtable from the language you wish to use, otherwise the game will use the default ones. So you may have English stringtables, but the help strings would still be French, for example.

You can also modify the uiinterfaceoptions.xaml file, that can be extracted from Game/UI/ Here, you can change the name that belongs to the language that you are using to host your mod.
For example, I changed French to English - Hungarian Civ Mod
On Line 598, from:
<ComboBoxItem Content="$$70883$$French"/>
<ComboBoxItem Content="$$91912$$English - Hungarian Civ Mod"/>

Changing the number from between the $$ dollar signs will mean that the mod will display a string from stringtabley.xml, instead of what it says beside the dollar signs.

Be advised that the order of the languages in this xaml file are important, as for example if you change what used to be Japanese and then go and place your stringtables in the Data/Strings/French folder, it will not work. The game will still be Japanese.

:arrow_forward: Did anything positive come out of this new change?

Maybe. If you’re like me, and often use mods, and IF you use this method of modding stringtables, you will only have to switch your language once, because the game will remember it. And it will always load your custom stringtables. The problem with this however, is if/when you decide to disable your mod, your game will be in a language you might not know. So switch back to English before disabling mods.

Thank you for your attention.


Really don’t understand why they changed this in the first place.

Has there been an update to this? I’m unable to update strings as well.

Can a moderator/developer/liaison confirm whether or not this is seen as a bug? I hope this will be resolved. The work around listed above essentially guarantees that mods will fail on every update where there is a new string.

I also have to imagine that a significant amount of mods are trying to work around this issue if they have any customization. And combining mods with text customization has got to be very difficult.

I tested as of the latest patch, and it is still (mostly) the same. You can toggle English on and off in the language options to get it working, but I find that more tedious than just replacing French or some other language. I hope this gets more traction so the devs notice and fix it soon!

This seems to have been fixed as of the latest patch! Thanks you AOE3DE Devs!


Hi there,

Can anyone please tell me how to make a campaign dialogue with both a portrait and a line of text. When I tried to import my stringtabley.xml(I’m pretty sure I got the correct folder format), and another called something like… wnpg into that data folder, it would not read my portrait…