Age of Empires 2 Definitive Edition user Privileges Error

When I launch the game I get this User Privileges Error show up and I can no longer play multiplayer, the option for it is grayed out and there is nothing online to tell me how to fix it. In most other games where windows doesn’t lock me out of the install directory I could go to the games exe and tell it to run as administrator.

user Privileges Error

Sorry, your account settings restrict you from certain features of the game. Please check your account settings on for more information. (OK Where, details people)

Also if i go into the games options all I get is a black void, waiting does nothing the only way out of this is to control alt delete and kill the games process. I can change the options but I need to play a single player game and can change it from the menu there.

No one from Microsoft gave me a cent to build my PC so its ironic then that they can lock me out of my own PC. Boy do i miss windows 7. I wish Bill Gates did give me a small loan of a million dollars id have a computer that would rival that of NASA.


I have the same frikn problem. There’s nothing on the web for help on this specific problem.

Hi there,

did anyone fix that problem? I have the same on my surface pro 7…


Don’t know how to edit on here. It’s 2020 Microsoft had time to fix this before Covid became a thing and now Covid is here… yay

So it’s 2020 I have still tried everything on here, I even bought the game on a superior platform Steam.

Now Microsoft I do think you guys are awesome however you need to fix a few things, No one should have to jump through 5-10 different web pages just to get to their privacy settings when I log in to my microsoft account I click privacy and there is a big list of everything else that reads more like a page just listing out the nice features you have instead there should be a link there to that setting games.

I found the correct page again after using Google, thats right microsoft users have to use Google search to find the correct page. You might want to fix that. So I change all the settings so Mark Zuckerberg now has my phone number and I guess everyone else at Microsoft. Every setting is set to allow. Somehow I still get the user privilege error in Age of Empires 2 Definitive Edition. Oddly every other game on Windows Store works online. Just not this one. I’ve read a lot of forums now even one about the game launching some task in task scheduler when the game runs and yeah that was fine still nothing seems to fix this. I hope someone is still alive at Microsoft I am starting to feel like Matt Damon living on Mars there never seems to be a reply to all these people, All I have left is my cynical humor. For an error that have been plaguing people on this platform for ages now.

I eventually bought the game again on Steam and it works. So I guess deceptive marketing practices to get me to buy the game more than once to get a working version of it worked on me.

did you get a refund on ms store? did you try to?

It is not a bug I used to have the same problem but I fixed it by changing my account settings.