Age of Empires 4 laptop 3080ti overload

Hello, AOE4 Developers!
I have very strange issue while playing ur great game!
My laptop is Razer Blade 17 2022 with 4k panel, 32gb and 3080Ti with 16 gb. This beast usually have great perfomance even in 4k, but when I play AOE4 it freezing a lot. I tried everything, but in max graphics i have 20-30 fps with freezing to 10-15. In minimum graphics i have 34-40 with freezing to 10-15. In Menu it is nearly 110 fps. Graphic card seems being overloaded and laptop became pretty hot, whats never happend in other games.

In other games like SC2 laptop performs in max setting smoothly 110-120 fps and remains cold and quiet.
I tried monitor perfomance, but in task manager there is no issue accept that in GPU graphics parameter Graphics_1 is overloaded, when 3D - not. For example in sc2 3D is loading a lot, but Graphics_1 - not at all.

That was the game with AI and it freezing at start. I have the latest drivers from Nvidia and all updates from windows. Also I checked, that AOE4 is in exceptions from Windows Defender.

Try lowering your resolution and let me know the results. Also download Hwinfo 64 so you can monitor your entire laptop hardware.