Age of Empires: Definitive Edition - Content Update 4 - Age of Empires


#21

My game hasn’t updated yet. I’m trying to do it manually, but it appears there’s no link anywhere in the known universe where I can just download the patch and update my bloody game.


#22

Keep it up. This game has been so much fun, any updates are great. A lot of ppl appreciate you bringing this title back


#23

Another week, another bust! For those who’ve awaited for the update that long, for nothing, i fell sorry for you.


#24

After many e-mails and solicitations, I find myself after spending € 20, which remains only once, as soon as you start a game the game stops by itself, the only thing that has changed since the last update, is that I do not return to the store.


#25

I’m really losing my faith that I’ll ever be able to play this game. I guess MS give a rat’s crap about us.


#26

Anyone that has a problem starting the game:

  1. Download ANY OTHER APP from the Microsoft Store
  2. Delete said app.
  3. Start AOE. it should work.

#27

Hola, inicie el juego normalmente y al entrar al multijugador me di cuenta que necesitaba actualizarce,entonces lo cerre y abri Microsoft store.Despues trate de abrir nuevamente el juego pero ahora me aparece un aviso donde dice que se esta actualizando age of empires y que podre jugar en breve pero no me lo permite. Que puedo hacer? GRACIAS


#28

Loving this game so far! Had no issues running it other than it not allowing me to play till it signs into the store, which is totally fine, although I hope this doesn’t mean I can’t play it offline (Haven’t tried yet).

I know I’m hearing lots of negativity, but whatever is causing the crashes is probably from when the game first released, because I bought it before the update and it worked perfectly.

Keep up the good work!


#29

@Leo5117 said:
I can’t play for 2 days and I try uninstall then install again!
It still can’t launch stable, May I get my money back?

@Leo5117, yes, it is possible to obtain a refund. There have been discussions about how to do so on other parts of this forum.


#30

Everyone here still having errors please follow the steps at https://www.ageofempires.com/support/#report
Or at least post your dxdiag.txt to the support forum. Launch dxdiag.exe then save and post the results.


#31

Game work only if I uninstall then install again! How I may get my money back?


#32

When is the next patch coming please?


#33

I bought the game on the 13th of March and it said quite clearly that this version contained fixes on the problem of the game crashing and the AI attacking too quickly. I’ve experienced both issues when I tried it out and though I managed the crashing one on my own, I still have a problem with the AI. Is it possible I got an earlier version? Is there a specific procedure to install bug-fixing patches? Any help would be great


#34

So now any time I try to load a saved game, AOE shuts down and goes back to Windows desktop. WTF? Any suggestions?


#35

Has the “Henry V” bug been dealt with yet? Literally, EVERY OTHER TIME I play this game, the names of the original leaders of the enemy force’s change and I’m battling several different Henry Vs.

The game I’m playing right now has me as a Byzantine, and I’m fighting Henry V of the Italians, Henry V of the Persians, Henry V of the Vikings, and Henry V of Ethiopia. WTH? And it’s been doing this for months. At first it was only a rare occurrence, but not it happens in 50% of the games I play and I’m tired of it!

Also, why are the Ethiopians Caucasian? Every African villager in this game is Caucasian, but the unique fighting units produced in the castles are Black. Shouldn’t they all be Black? What gives?

I’ve enjoyed this game since it’s original inception. The addition of the extra civilizations add a greater diversity which I love, but these are two issues which need to be fixed.

Scourge2


#36

I am having troubles with low FPS in this game, although I am playing AoE 3 on high (almost ultra) graphics settings with 50+ FPS even in battles, but in AoE DE all what I need to make it lag is just to zoom out for a bit and here it is - 15 FPS.

I also dont understand why the game’s weight is 20 GB (but it takes ~25 GB for me) when the original game’s weight is 64 MB. Why this game has such size and will it be fixed later?


#37

The Old game units have three different attack animation can you add on this game too? and what about changing the units upgrades likely in aoe2. last thing this game need rating system on online play


#38

It’s worked perfectly fine, after the windows actualization. The game is perfect, now I can played normally. Previously i used Max8987 and others advice with app from Microsoft Store.


#39

I’d like to play with an easy IA, it is too difficult and I do not want to play like crazy clicker. Just I want take my time while playing.
AND I want to play without Wonder to set Victory.
Are there solutions please ?


#40

All okay, AI is not to hard, I have played all missions, in Standard (Sorry for my english)