Age of empires II: Definitive Edition - Game Pass multiplayer with family members

Hello everyone, I have a game pass and I have my wife and both of my kids as family members in my Xbox profile. Making us able to install and play Xbox PC Anywhere games on our respective PC without having to fight for 1 computer (we are on the same lan). We all have our respective computers and they are all added under my preferred devices in my Microsoft account. This also give us the ability to play 1 game together (we have lots of fun doing it) with the exception of AOEII Def. Ed.

For example I am able to add my wife to my lobby (2 Players vs 1 AI), game starts but after around 12-15 min she gets kicked out of the game. Game is closing entirely, no error message. She showed as resigned on my game. I’m able to continue playing on my side without problem.

I updated to the latest version this week and issue persist. Don’t know if it’s something somebody else is experiencing this problem ?

We experienced the same experience on our end. Seems like the game only runs fine when there’s up to 2 people on the same game licence.
Hope this helps
Good luck !

Also if you found something else would love to know!

I’m having the same problem when trying to play with my son. It seems very streange that the game is closing without any error message. Seems like a bug to me. Did anyone find a solution to this? Is it obvious that it will work if I buy a second license?

To answer all those questions, I have to say the only fix I found was to buy another license for AOE. I find this is sad that people living under the same roof has to buy copies of the same game to play together. AOE II is such a great game that I think it’s money well invested.

Thanks, I can conform that it worked for me too after buying another license.

Sorry for resurrecting an old topic.

Family account (Myself, Wife, Kid)
AOE II HD Edition (one license)

I can play solo (1v?) fine
I can start / join Multiplayer games from any of the three accounts
I CANNOT find a multiplayer game started by another family member (Wife starts, Myself and Kid cannot find it at all)

I have no issue buying another license, but I want to confirm this fixed your issues, and I am curious if I need to do something else as well.


Hello Hobie76, I had the same problem when the version on AOEII was different. Make sure you are all running the same version.

I appreciate the quick note.

Both versions of the game are: 101.101.40220.0.0

Same LAN, both connected to the internet.

When you bought the second license, was it just buying another games (same AOE 2 Def…) under the same Microsoft Account? so it would show up twice.


No, I bought it under my son’s profile not mine. Just to avoid any issues. You can buy as gift, use your Game pass special discount and send to another user.

I think this is a different problem, but I have experienced that as well. I got it to work by adding Windows firewall rules to allow incoming traffic on UDP port 9999 and TCP port 8888. It is actually only necessary to add TCP port 8888 to the computer hosting the game, and UDP port 9999 to the clients joining that game.

This is in addition to the predefined rule “Age of Empires II: Definitive Edition” that was added automatically during installation.

But even after doing that I can only see the games created on my computer, not on my son’s computer. Sometimes it works to find the game by searching by game ID, but often we get an error message when trying to connect. Now we have basically given up and are only hosting games from my computer.

It’s really amazing how this can work so badly in 2020. It worked better when I played 20 years ago.