Age of Empires III: Definitive Edition — Update 29715

Age of Empires III: DE — Update 29715

Welcome back explorers, and thanks for joining us as we dive into what’s new in the latest update for Age of Empires III: Definitive Edition!

Today’s update brings with it a number of exciting features and fixes as we strive to provide the very best experience possible. Curious what’s in store? Here’s just a small peek at what’s new in this update:

  • A new “extended” pop-out minimap feature, providing a better view of the battlefield!
  • A new “Home City Mini Deck” has been added to the in-game interface, allowing for more streamlined management of Home City shipments.
  • A new chat popover on the post-game summary screen.

Head on over to the link below to check out the full patch notes!

:scroll: Read up on the Changes: Age of Empires III: DE — Update 29715

:scroll: Read up on the Hotfix: Age of Empires III: DE — Hotfix 30181


Learn More…

:speech_balloon: Join the Discussion: Age of Empires III: Definitive Edition

:smiley: Get Involved: Age of Empires on Discord

Enjoy!

4 Likes

Everything feels so wrong after this update…

  1. Economic gather points show the wrong resource symbol ~half the time. Axe when clicking on food, regular cursor when clicking on coin, meat when clicking on trees, etc.

  2. Cannot levy minutemen as USA

  3. severe performance issues (fps drops)

  4. Units appear smaller (possible illusion due to larger HP bars)?

  5. Textures are grainy? Graphics appear off

  6. See enemy flares in team

6 Likes

Yeah, every game I’ve played since the update is very laggy, other people are having the same issue. Also I can’t click to hunt a deer if it’s through the trees anymore, cursor will only have the ax symbol.

1 Like

omg, roll back asap, its unplayable … :frowning:

1 Like

If only AoE II: DE got features like this for it’s updates.

1 Like

Hi,

I also got a lot lagg after the update, and some how my video cart temp is jumping to 80 degrees in just 2 minuts of gameplay ( 2v2 AI) before the update my temp stayed at 50 degrees (1080 8GB Gforce)

GauiX7

With this update, my graphics also appear to be grainy and low res. Everything is on High.

Also, for whatever reason, when placing a building in an inappropriate location the red square no longer appears or appears cut off. Very annoying when trying to rotate buildings or placing walls.

Another thing I would like to mention is that when I played a game last night with my partner, they were unable to place a Market right next to their TC in Treaty mode.

I’ll see if verifying the game’s integrity on Steam will solve anything first before moving onto other options.

EDIT: Verifying the games files returned no abnormalities.

Hey everyone, we just released a hotfix to address some of the issues you’ve flagged for us. Please let us know if this helps and if anything else comes up or still needs to be addressed. Hotfix patch notes are at the bottom of the original patch notes and can be found directly here. Thanks for your patience!

:scroll: Read up on the Hotfix: Age of Empires III: DE — Hotfix 30181

3 Likes

does not work for me. The game still lagging for no reason, can’t find lobbys…

1 Like

This update don’t let me find any local multiplayer game, it doesn’t appear anything jn the browse area

Are you by chance playing on the Microsoft store version of the game? If so, the hotfix there just went live yesterday. Do you mind trying again and seeing if that helps?

Are you by chance playing on the Microsoft store version of the game? If so, the hotfix there just went live yesterday. Do you mind trying again and seeing if that helps?