Age of Mythology doesn't launch on steam

I bought AoM on Steam. I tried several times to play but the game won’t start. To be precise, i click on “play” after installign the game. Then the launcher opens up. I start the game with it, my screen turns black like it is charging the game. Then the game shuts off before i arrive to the main menu or the cinematic of introduction and i am back on steam like nothing happened. Same reseult when i choose the bypass the launcher option on steam. I tried to update my OS and my drivers and it didn’t work.

Can you help me ?

My problem is solved without the help of anyone, maybe the latest update but there is no mention in the logs, i can play, that’s good.

Hello Courbe!
I have the same problem as you,I just can’t play
How did you solve your problem?
I will be grateful if you tell me. :slight_smile:

Following this thread, because I can’t seem to get past the launcher menu for AoM on a brand new computer. I even did the verify files step that Steam recommends. Any and all help with this will be much appreciated!