Age Up Info Missing From Tooltip

:arrow_forward: GAME INFORMATION

  • BUILD #: 4#####
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

When hovering over the age up button when the town center is selected the resource cost, and additional information to age up is missing from the tooltip. It had nothing to do with Extended Tooltips, as that option was never selected before. Still, some basic information’s are missing.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

Every game.

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  • Select the town center and hover your mouse over the age up button to the Feudal Age.
  • View the tooltip and observe that the resource cost and information is missing.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

1 Like

I thought I had this or a similar issue when it first launched and for a while thereafter. I was never sure, though, so I never reported. (I was too busy playing the game not wanting to lose, and figured I was probably doing something wrong or looking for the info in the wrong place. :slight_smile: ) It was random for me, though; I’m pretty sure it did not happen in every game.

I wonder if it’s been lingering all this time, or if it went away and has come back

1 Like

Even though it is a small error, it is still so annoying for me and it bugs me what is the problem. Tried verifying files, didn’t help, thought of changing Toltips file with another one, but no one know what is that file. I don’t know even if reinstalling game would help, and that is not something i am still willing to try, so i hope someone will know the solution to the problem.

1 Like

Oh, I agree. It was really annoying for me, too. Even though I’ve played the game a ton and know the age up requirements, I guess it’s just one of those visual mechanisms I’ve always noticed and paid attention to, no matter how subconscious. So when it was missing, I definitely noticed and was annoyed by it.

Actually, I just started a game to test on my end… shouldn’t the Age Up icon be showing from the very beginning but dimmed out or red? Seems like this is what my problem was since launch. I tried with Extended Tooltips and without, but same issue.


In AoE2:HD, for comparison, it has the Age Up icon from the very start:


(Sigh, I really miss that tooltip style, with small font and semi-transparent backdrop)

The AoE2:HD approach makes most sense to me. Why would you not want to have the Age Up icon visible at all times so you can hover over it and see what resources are needed?

And then to the OP’s point, the resource cost should also always be available to see when hovering over the Age Up icon (an icon that should always be visible)

1 Like

Yes, Age icon should be there from the beginning. Maybe you selected starting from Imperial Age when starting the game, and that is why it is not there? In my case, I have an Icon, but that text (Cost:500 Food; two Dark Age buildings) is missing, and then same happens with Castle and Imp age as well.

Uh oh, let me check. You might be right… (and probably are). I don’t normally do that, but to meet some of the event challenges, I’ll do that

EDIT: Yeah, that was it. Sorry for the false alarm. Thanks for letting me know! Here’s what I see when starting from Dark Age (looks good)…


I think I’m sorting things out in my mind surrounding the tooltips and such, though. My issue was that Extended Tooltips kept getting disabled, possibly with patches that got released. When this happened, I’m kind’ve thinking the Age Up cost didn’t show in the tooltip anymore(?)

I know you say you haven’t needed to have Extended Tooltips on, but have you been playing AoE2:DE since the start of the year? (Your forum profile says you joined in September, so I thought maybe the game is fairly new for you.) If you didn’t get the game until September’ish, it may be a case where early in the year, the Age Up cost didn’t show unless Extended Tooltips was enabled, and then they maybe fixed it mid-year to show up no matter if enabled or disabled (for when you started playing(?)), and then now late-year the cost only shows for Extended again?

I am playing it every day basically, for the last 9-10 months, and issue only started today. It is shown with complete explanation when selecting Extended Tooltips in settings, but without it, it shows nothing, and before it always showed those basic things, like food cost and additional buildings.

Extended Tooltips was always OFF for me, but I had those basic information’s. Now, for Age Up, they are not available, but are available for other things.

Have you tried seeing Age Up information’s without Extended Tooltips selected? I know this was possible since I started playing, and like I said, it only started happening today.

Also, cost and that basic info is missing only for Age Up, so it is for sure some kind of a BUG, and not a default option.

Guys, anyone has the same problem? Has anyone tried to see if he gets these options without Extended Tooltips? This is so annoying for me, and I am even thinking of completely reinstalling the game to see if something will change.

1 Like

Yeah, I have same issue when Extended is disabled. I failed to clarify that above, but it was my experience yesterday

Oh, wait. Is my post the solution, though, @GMEvangelos? I see you marked it as such. I was just letting @KingPupka know I had the same issue as them, but I wasn’t giving a solution :smiley:

I think KingPupka and I both agree that the basic tooltips should have cost info in them. And with KingPupka saying it has been that way up until recently, it could be a bug

Well, they didn’t even care to reply and give us their thoughts or anything. It is easier this way for them, to put it under a rug and keep moving on, at least for them, it seems.

Issue is not that big, but still, to need to use Extended Tooltips, just to have that information’s, that is really poor and unnecessary.

Maybe it will be back in future patch, hotfix or update, or they will just ignore it.

Anyways, thank you @Darkness01101 for helping and giving your thoughts on the issue as well.

You bet! Sorry if I clouded the real issue through all my words, though. I may have very well misled GMEvangelos a bit due to the various things I talked about :smiley:

I don’t think it was meant to be swept under the rug. I think it was just because of me talking too much as I tried to dig up my old memories/experiences from months ago and wondering if they were related in a roundabout way… something I said maybe sounded like I was giving a solution :stuck_out_tongue:

No problems mate, you had best intentions! As for the issue, like is said, it is not that of a big deal, but still, for those basic information’s for Age Up to be available with Extended Tooltips Off, that would be great for sure.

1 Like