"Toggle Extended Tooltips" keeps getting disabled with each new patch, I'm pretty sure

Game Version:

  • Latest build (34793)
  • Steam

Issue:

I’ve tried to have “Extended Tooltips” enabled ever since I got AoE2:DE, but instead I’ve had to re-enable it two or three times since I bought it. The latest occurrence was tonight after installing the latest patch. Either it’s coincidence that the patch did it tonight, my first match after getting the patch, or something else keeps disabling it.

Reproduction Steps:

  1. Enable extended tooltips in an earlier build
  2. Install the new build and see (hopefully) that it’s disabled

Fortunately, I played a single-player game and noticed it happened before playing multiplayer. The issue actually negatively impacted me a week or two back when I played online multiplayer and the extended tooltips had gotten unknowingly turned off by the bug, so I didn’t exactly know which units I should build to counter enemy units. I re-enabled them after that game and played some matches since then and it remembered my choice. Then tonight after the patch, it was reverted.

No matter the cause, I really wish it would remember my choice forever so it doesn’t negatively impact my gameplay and online matches.

1 Like

I have the same problem

1 Like

Game Version:

  • Build (34793)
  • Platform (Steam)

Issue:

Extended Tooltips Options get disabled each new game. (SP or MP or Campaign won’t differ)

Reproduction Steps:

  1. Not exactly sure what causes it
1 Like

I noticed yesterday there may be a hotkey for this toggle of “F1”… (for the HD hotkeys preset anyways. DE preset may be different but is likely the same).

I know for a fact that I never hit F1, so that potential cause can be ruled out for me. Are you able to say you also never hit F1 to accidentally turn the extended tooltips off

I’m very sure I never hit F1 like, ever

1 Like

I am sure, that F1 is supposed to toggle tooltips only in current game, not permanently through changing option value.

Not sure. Seems like that would be a preference it should remember globally, though. I think AoE2, historically, remembers forever your preference for displaying player scores in lower-right (F4), for example

Same issue, was resetting on each new campaign mission

1 Like

Yeah, for me, I think it reset again… even though I’ve not loaded a new patch :frowning: I think it might just be a problem with the game, in general. I was playing online MP last night, and when opponent started attacking me, I went to build units to defend, but the extended tooltips was off again! And I wasn’t positive I knew what would archery units would defend decently against infantry. Luckily, F1 worked. But, still… wasted time, when every second counts.

any help about that ?

1 Like

I think F1 is the hotkey

i tried that many times and i use default hotkeys… it did not help

No help yet; no word yet. Still, every patch, or just about every patch, it reverts to being disabled :-/

Hello everyone! I’m afraid our Test team has not been able to reproduce this experience, so I was wondering whether this occurred after Wednesday’s update (37650). If it did, can you please include as much information as you can about your experience, such as:

  • The platform where you are playing the game.
  • Whether the game is saved in a read-only folder.
  • Whether (as @Darkness01101 mentioned) there is a hotkey being pressed to disable the tooltips.
  • A full list of the mods you are running.
  • Any other details that will help us understand why this is happening for you.

Thanks for the reports, and I look forward to hearing from you!

1 Like

Thanks, GMEvangelos! Will do, next time I experience it.

After installing the new patch the other day, I checked nearly right away and noticed the setting did not get disabled, thankfully.

I will keep an eye on it in case it happens later on. And if it it does happen, I will try to answer your list of questions as best I can

1 Like

I changed the hotkey of Toggle Extended Tooltips – I don’t want to sacrifice the F1 button for it. Unfortunately, changing the hotkey doesn’t seem to work: I can’t enable or disable Extended Tooltips in-game with a hotkey. The only way I can enable or disable it is by changing it manually in the Options menu. Seems like a bug to me?

2 Likes

Hi @GMEvangelos - I had this issue happen again with the latest patch.

To answer your questions:

  • The platform where you are playing the game - Steam
  • Whether the game is saved in a read-only folder - It is not in a read-only folder. I checked the security tab of all folders in the game’s hierarchy within the Steam game path and they all have Read/Write ability
  • Whether there is a hotkey being pressed to disable the tooltips. - I’m not hitting the hotkey (F1)
  • A full list of the mods you are running. The only one that was active was: "[Jan2021] NYE Town Center Decoration"
    image
  • Any other details that will help us understand why this is happening for you. - No idea. Just seems to automatically happen sometimes the first game I play after devs install a new patch. For me, I usually play a “2 humans vs. 2 (or 3) AI” game, I usually play as Spanish and teammate as Korean (with AI civs being, more or less, randomly picked), and I create the lobby (‘westus2’ server). I’m pretty sure it’s happened before on single-player games when that’s been the first game I play after a given patch; but since I play the above setup more often than not, it’s my current example and a setup in which it has happened before.

It happened this most recent time after updating to the latest build: Build 44834.

I normally find out it’s disabled when I hover over units build icons at the military buildings to see which units are good at countering which units. I immediately know the Extended Tooltips are off because no information about this is provided in the tooltip. When this happens, I have to quickly go to the menu settings mid-match and re-enable the Extended Tooltips, as I usually don’t remember with 100% certainty what the hotkey is (i.e., I’d rather be safe than sorry)

Thanks! Please let me know if you have other questions

1 Like

Thank you for all of the additional information. I’ve re-opened the investigation with our Test team to see what they can learn.

Assuming they will not see the same behavior, I want to continue trying to narrow down the factors that may be causing this for some and not others. few more questions, to see if the answers can help the team:

  • Are you using Steam Cloud saves?
  • If you are running a firewall or antivirus program, have you added the Age II folders as an exception?
  • Is the game installed on a secondary/external hard drive?
  • Are you running a beta build or enhanced logging build rather than the base game?
  • Would you mind sharing a copy of your dxdiag file for review?

Let me know and I’ll get this information passed along, and thank you!

You’re welcome! Here are those details:

PS: If it helps...

  • I run “SKIPINTRO” as a launch option:
    image
  • On the bright side, I just installed the Feb. 11th Hotfix and launched a single-player game and the Extended Tooltips were enabled. Then I created a private multi-player game as I normally would, and they were still enabled. So they didn’t reset this time! I think I’ve noticed the issue happen moreso with the major monthly updates/patches, though, if I’m not mistaken
1 Like

A quick update: The game is installed on Steam on my D:\ drive, but I just noticed that my C:\ drive’s “Games” folder and the “Age of Empires 2 DE” sub-folder are set to “Read Only.”

  • And I now see my “AoE2DE” folder in my Steam folder on the D:\ drive says the same thing. “Read-only” on the folder, but then the Security tab shows “Read” and “Write” capabilities for all groups and usernames on my system. I had been looking at the ‘Security’ tab in my post 4 days ago.*

Is that okay? Could that be getting in the way? I didn’t manually set it that way. The game or something would have done that…

But then if I go into the Security tab of this folder or files within the folder, they say this for all groups and usernames on my system:
image

So, it’s a little confusing. Seems contradictory to me to say “Read-only”, but then you dive in and see “Read an Write” permissions allowed…

1 Like