[AI Modding] Unable to see AIEchoes or any of its output in .txt files

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 63727
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

As mentioned in Update 61213 released February 1, near the bottom where it says “Interesting information for AI modders…” new configurations were added to support AI modding.

First, I followed the instructions and created the user.cfg file in the correct Startup folder. Then, I used the new configurations listed within the file to try to see the AI Echoes and constants.

Using the “generateAIConstants” line in this file, this information was generated successfully - each AI of the previous game having generated a list of constants that the game uses (these are all identical). These are titled like “Age3DEAIConstantsPlayer2” for example.

The patch notes also say that:

aiEchoes are no longer generated by default. You must now put showAiEchoes in your user.cfg to see them again

However, I never saw them to begin with before this update using the debugger. I do not know if I was doing it incorrectly. Nevertheless, I tried this and still cannot see them within the game. I am not sure where to see them. I tried both using a lowercase “i” and an uppercase one in the “AI” portion of this command - both did nothing.

I did not mind viewing them in text format, however, so I tried the following command also listed in the patch:

You can now generate text files with all the aiEchoes per AI of the previous game you played by putting generateAIEchoesOutput in your user.cfg. Text files will be named like “Age3DEAIOutputPlayer1.txt”.

Although this command does create the text files - one for each AI player - the files are empty, and nothing was generated within the files. I made sure at least some AIEchoes were being called in my file, but nothing happens with them. If I want to debug myself, currently I have to use the aiChat function within the game.

There may be an easy explanation to something I am doing improperly, but seeing as this file generates, I know my user.cfg is working, so I do not know where the issue lies.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Follow the patch note 61213 instructions on creating a user.cfg file in the correct Startup folder.
  2. List these configurations mentioned.
  3. Have your AI files make use of the aiEcho function.
  4. Proceed to find no AI Echoes within the game, or in the created text files that should list them.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
I expected to find the AI Echoes generated somewhere in real time using “ShowAIEchoes”.
I also expected the text files to include the AI Echo output after using “generategenerateAIEchoesOutput”.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


:arrow_forward: GAME FILES (SAVE / RECORDING)


Hello @NewMercies1775, Apologies for the late reply. We’re tracking this issue!

1 Like

Thank you devs. This issue is fixed with the latest patch!

1 Like