AI not responding when restoring

Game Version:

  • Build (101.101.35209.0.4667120)


I played a match with one friend vs 2 AI. My friend’s game disconnected, but amazingly, it was auto-saved (nice feature!). When he tried to restore, the AI was mostly not responding. Some villagers were still working but most were idle and no advancing of ages and new constructions were observed. In another match, same thing happened: my friend disconnected and an auto-saved was generated. This time I (who created the original lobby in both cases) tried to restore. We restored the match and the AI played correctly as intended. My suspicious is that the same player that creates the lobby has to restore it for the AI to not freeze.

Reproduction Steps:

  1. Start a mutiplayer match
  2. Have a player that did not start the lobby disconnected
  3. The player that disconnected (not original lobby creator) tries to restore match.
  4. Match restarts, but AI doesn’t work as intended and are mostly idle.

A post was merged into an existing topic: AI behaving weirdly on reloaded game