AI Script Error since the Lords of the West DLC

Since the new Lords of the West DLC, I get this error whenever I start any game:
AI Script Error
File: Promisory\init.per2
Line 180: ERR2005:Invalid identifier:
ERR2004: Missing identifier: tc

The AI basically does nothing in any such game. And I also get an error looking at recorded multiplayer games.

I have tried:

  • reinstalling the game
  • unsubscribing from all mods
  • deleting all local files and reinstalling
  • deleting all game files and reinstalling
  • deleting specifically this file and reinstalling

All have had no effect. Any ideas what to do?

I have the same error, did you find a way to fix it?

No, I haven’t found any fix that works yet

Try deactivating the mod for The Forgotten HD Campaigns


Exactly what I did and it worked.

1 Like

I don’t have any mods

Hey Dafidius, this should be related to a mod as previous posters mentioned (especially the The Forgotten HD Campaigns mod seems to modify AI files).

If you don’t have any mods and all the steps you mentioned above didn’t work for you, could you then try the following:
Go to C:\Users[username]\AppData\Local\Temp and delete any folder (and all of its contents) with the name “Promisory”, additionally you can also delete any .per file in that file structure.