AI Script Error

:arrow_forward: GAME INFORMATION

  • BUILD #: 5867313
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

«Error Player#
File: Promisory\Buildings.Per2
Line 2851: ERR2005: Invalid
Identifier: ERR2004: Missing
Identifier: Rushprep-Cost»

:arrow_forward: FREQUENCY OF ISSUE

Each game.

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:
I just started a game.



I have also been experiencing this exact same issue since the November update. I have attempted to validate game files, uninstall and reinstall, and even modify the buildings.per file to define values in the Rushprep-Cost, fiprep-cost, flushprep-cost, and boomprep-cost lines of the script. This did not fix it, unfortunately. I haven’t been able to play a single-player match since this bug started.

I have the same problem. Sometimes I can play but it happens only with my personalized maps.

Exact same problem here

After new upgrade, now I have this error.

AI script error player 2 file: promisory/init.per2 line 995:ERR2005: invalid identifier: ERR2004: missing identifier: watch-tower-building
This happens when I try to play a custom scenario and the erroe appears just before it finishes uploading the game.


I’m also having this issue on my custom scenario. I also noticed it only happens on the DE AI. The HD and CD version work just fine though and no error occurs.


I have the AI Script Error issue as well since the new update. If I start any singleplayer match, regardless of the number of bots in the match, I get this message:

AI Script Error
Player 2
File: Promisory\init.per2
Line 180: ERR2005: Invalid identifier:
ERR2004: Missing identifier: tc

I observed the AIs and they are completly broken and just start wondeering around with their villagers aimlessly. I tried verifying the game data and also deleted the AI folder once to redownload it via the verification, which both did not help.

EDIT: SOLVED by deinstalling any AI packs. Eventhough the only AI mod I had was the Barbarian AI (and I assumed this doesnt touch the main AI at all), it seemed to have caused the AI script error.
@InphaseAutumn3 @PiddlingPants12 does this work for you guys too? try removing any mods related to AIs


I have no ai packs and I have the same issue. Tried deleting those files and redownloading them via verify cache and I still get this error.

1 Like

I find these errors while booting up skirmishes. It seems if any player chooses the new civs such error arises and AI goes mental. But no issues when playing without new civs. Even tried playing with Barbarian AI. The new civs are what messing with single player mode.

1 Like

The civ doesn’t matter, only the type of the ai that I pick. if at least one players uses the de AI, i get this error on game start.

1 Like

Since I got the new DLC I get the following, no matter what civs where selected

1 Like

OK. Possible solution. I had all these problems, but I “created” a new file of the scenario just updating with a new: cow, building, rock, etc. I have played many games so far and the error hasn´t appeared againg. Hope this works for you.

Fixed by deleting the whole game and all config/scenario/ai files and whatever else i could find and reinstalling. Nothing else helped :confused:

I am also getting this error. I cannot play any skirmish game as the enemy just freezes, the only functionally they have left is their scout, all vills are frozen and their TC must be idle.

I have tried to verify integrity of game files, and even uninstalled and reinstalled, neither of these helped.

I’m just hoping the devs put out a patch for this.

This is so frustrating. I am getting this issue and have tried everything:

  • deleting all the files
  • reinstalling from scratch
  • I have unsubscribed from every mod

Single player currently unplayable

1 Like

what has worked for me is to enter the “ai” folder in
"\resources\ _common\ai"

and delete all the content. I don’t know if this solution works for you

Another thing that worked for me was to delete all the contents of the “ai” folder of the installation

and then in “steam” in game properties, in the local files option and press “verify files”


I hope it works for you


That has not worked for me. It must be this update’s files that messed up the AI for some of us.

Edit: New update came out moments ago and it seems to be fixed for me. Let’s hope it doesn’t come back.

1 Like

Thank you, that is really helpful!, but I still get the error :frowning:

I had gotten rid of the issue time ago without any change, but now it came back.

Let me try, though I don’t remember having any AI. Trying Metalchairo’s proposal.