AI script error

Game Version:


I started a game with 300pop cap at extreme difficulty. And a message saying that “AI script error” pops up when the game starts. It happens in both single player and multiplayer and it seems that the message appears when AI(CD) is present.
I didn’t enable any mods and I tried it with my friends, the message only appears on the host side, but both of us get the error messages under the same lobby setting.

Reproduction Steps:

  1. Start a game with 8 players including at least one AI(CD)
  2. Difficulty: Extreme, Pop cap: 300, map size: large, the rest are default.


1 Like

Yup, I’m getting a similar script error.

All standard settings, but happens on any AI difficulty, with the normal DE AI too.

Tried reinstalling and verifying files (steam). Nothing helps.

I used to have a problem pre-update where the AI gave up, but only getting this error post-update.

Game is essentially unplayable now, as AI does nothing


Hello everyone, the error message shown in the screenshot in the OP only appears when the CD version AI is present in a game on Extreme difficulty but can safely be ignored as the AI will still perform as intended. This issue is currently being tracked.

BoorishEmu27471 on first glance your issue seems to be with missing or modified files but maybe there’s more, could you attach a picture of the exact settings you are using to reproduce this?

Thank you again for the reports.

1 Like

Happily !

I’ve reproduced it a few times, different game modes etc.

and still gotten the same error

Thanks ! It’s really great to know you guys are taking an active interest in all this

2 posts were merged into an existing topic: ERROR IA (HD VERSION)