AI stops playing

Hi all,

I’m playing alone against 3 very difficult AI’s and in the past this worked really well. However, since a week or two ago, the AI simply stops playing. I have to say that I am using the Advanced Game Settings mod and have a 40 minutes treaty before bloodshed. Also, I have started to cut the AI off of resources by building walls and/or palisades very far into enemy territory and I am wondering whether this may have something to do with this, that is, if the AI can not get to the resources, does it simply stop? I’ve previously seen this ‘stop playing’ behaviour when the resources on the map were running out, hence I’m wondering if this is related.

Is anybody else experiencing similar issues?


1 Like

Well, when resources get depleted on the map, you as the player have to get a little more creative to continue funding your army. The AI would not know how to do that I guess. So it is forced to basically stop. On the other side, if you’re walling off resources from them, the same thing will happen. Like if you build a wall around the AI’s town, they will also stop doing anything then. I think it’s pretty normal behavior for AI in 99% of RTS games.

Thanks for your thoughts on this. Just a few more points to add to the picture/situation. When I wall off resources, the AI still has plenty of resources on ‘their’ side. Also, previously, when I built walls, the AI tried to get through them to get to the resources (this mostly happened towards the end of the game when resources got scarce). I recently played with 3 friends against 3 very difficult AI’s and the same thing happened. On that note, I’m not sure if it happens when I a) don’t wall off at all or b) don’t use the ‘Advanced Settings’ mod. It’s just weird because everything was working as I would expect it to, until the most recent patch.

Ok, so today I tried a game without building massive wall structures and even about 15 minutes into the game, 2 AI’s simply stopped developing. This is very odd. If anyone has an idea why this happens, I would be most grateful for any thoughts.

I’ve seen that happen extremely rarely with Mongol AI, they just fail to ‘start’ and spend 10-15 minutes doing nothing. I’ve also managed to glitch an English AI into garrisoning all 14 of its villagers in the TC for over 10 minutes because of 1 spearmen standing on the edge of TC arrow range.

The AI is too deeply broken to try to decipher what’s going on. Sounds like it’s most likely the mod you’re using.