Algirdas & Kestutis Mission 5 CTD and achievement bug

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Version 101.101.54684.0 7486483
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


This is my first forum post in years, apologies for mistakes.
I cannot get the Steam achievement “Bond of Brothers” for completing the mission “in the Shadow of the Throne” in the “Alrgidas and Kestutis” Campaign. I have the Standard difficulty medals for completing the other four missions, but I cannot get the in-game medal and achievement for this one.

in the mission itself, when choosing to bring Jogaila into Trakai’s or Kreva’s town center, the game will crash immediately as soon as the control is given from the neutral Lithuanians to me. This will happen to both locations. I have found a fix online though, to set Lithuania to Neutral, destroy the Town Center without Jogaila, and then bringing him in. A new free town center will spawn in my control and the mission goes as normal without the crash.

However I did not do this at first, and through the frustration of being unable to progress, I actually used the cheat “i r winner” to automatically complete the mission. No achievement, which I should have expected. So then I took a few hours to look up the CTD fix, completed the mission “legitimately”, no achievement. Tried Kreva instead of Trakai, tried to defeat Vytautas before Kestutis, allied with the Teutons instead of the Pagans, played on Moderate instead of Standard, even tried on a different PC (same account), nothing.

Of course this is all nothing too important, but I do love some rare steam achievements, so I hope one day either of these are patched or that I can find a solution.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start the “In the Shadow of the Throne” mission and (probably not even needed) successfully bring the Ransom to Kestutis
  2. Open the chat box and type the cheat code “i r winner”
  3. Restart the mission and deliver the ransom
  4. In the Diplomacy menu, set the ally Blue Lithuania to neutral.
  5. Head towards either Trakai or Kreva, and destroy that town’s town center.
  6. set Blue Lithuania to ally.
  7. Bring Jogaila in front of the destroyed town center to complete the objective.
  8. Continue the mission as originally intended, build an army, defeat Kestutis and Vytautas

There is a detail that might have contributed to this but I am not sure.

  1. Start the “In the Shadow of the Throne” mission and (probably not even needed) successfully bring the Ransom to Kestutis
  2. Save the game
  3. Open the chat box and type the cheat code “i r winner”
  4. Load the saved game
  5. [Continue as intended]

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

I am supposed to get a bronze or silver medal for completing the mission in Standard or Moderate difficulty. I am also supposed to get the steam achievement for just completing the mission.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Processing: TRAKAI.aoe2spgame…
unfortunately it says new users cannot upload attachments. I am able to send the save file through gmail, plus a .aoe2record file if needed.

after a bit of looking around i see that the Crashing has already been noted

but also that the “i r winner” cheat may be the primary perpetrator by permanently disabling achievements and even medals for missions

Achievements works. thanks

I’m having the same issue. (Aside from the achievement)

Hello everyone. I had the same issue on the Jadwiga mission 3, the duel of the dukes. It’s REALLY difficult mission on hard and i used the cheat code torpedo(number) to win. But after i found a strategy and won the mission WITHOUT CHEATS. I won that mission many times, with saves, no saves, disconnected from internet ect with no luck. I finished the campaign and got the gold medal on the world map, but i didn’t received the achievement for finishing the campaign and the medal on that mission. Has anyone found a solution or anything that might work?