Annoying tick tick sound while watching replays

Game Version: 101.101.36202.0

  • Platform (Steam)

Issue:

Whenever I’m trying to watch any replays of my saved games. I hear some annoying sound while moving the pointer. And also not able to switch to the other player’s view.

Reproduction Steps:

  1. Go to main menu
  2. Click on save & replays
  3. select replays tab
  4. select any game to replay to play
  5. Now try to switch to other player’s view( Can’t switch)
  6. Try to move the mouse. (Annoying sound while moving the mouse)

1 Like

Hi there! I’ve seen this reported by one other players. They were able to get rid of the sound by setting their hotkeys to default. It seems like it may have been caused by using extra buttons on the mouse in hotkeys.

Let me know if this works for you!

No need to go back to default. You need to set a hotkey for ‘watch player x’ for each player to stop this behavior. That’s how I fixed it. Your ‘civ picking’ menu will now work, as well as your hotkeys, and the annoying sound will stop. Mark this post as solution when this solves it.

2 Likes

My recorded games are not working as intended. When i open a recorded game, i can’t change from player point of view to an other. Also, i don’t seem to be able to click any buildings, villagers or/and units. When moving the mouse, i hear a weird noise. Anyone else experiencing the same issue?

Video for what i mean=> https://youtu.be/KNbhzUx3N-U

Thanks dude. It was indeed my keybindings. I set them to default and rearranged them again and it worked for me.