Anyone figure out how to fix endless loading? (Devs DOWN?)

Mmm, yeah.

Ever since me and my buddy started Gamin’ it up in the Age of ____ games again, we’ve been having continuous problems with Age 3 Definitive edition.

When we try to load into a game, it is a 50/50 chance on whether I will load in, or endlessly be staring at some dashing British soldiers until the end of time (AKA, when I give up and task manager yeet it.)

Loading bar gets stuck at approximately 35% judging just by my eyeballs.

Now I know about 400 of you are frothing at the mouths to start screaming at me about anti viruses, but my anti-virus has been off and disabled for about a week, as well as windows defender, my computer has literally no active scanning or firewall operating (come at me l33t haxors) and it has made No difference whatsoever.

I transferred the game to my C: drive SSD off of my D: drive HDD, and it loaded in after about a minute the first two times, and then it stopped working entirely again except for one or two attempts where it would load in about 15 seconds.

I don’t know what else I can do, because my internet stronk, I have 30ms ping on average to the server I’m connecting to, No anti virus whatsoever, on an SSD, this is wack yo.

Just tried today, I hosted the game this time, we BOTH got stuck at the same part, then he randomly loaded in and was forced to instantly resign, while I was still stuck loading. Ooooookay. Go on. Slow down. Thanks.


try to completely reinstall your game to your SSD, it is a bad idea to transfer from 1 HDD to another and can sometimes cause issues for games.

next question is obviously to ask about your other system component, esp ram and CPU.

That’s not even like how that works bruh. I have transferred several hundreds of games.

1 Like

Never, ever, ever had any kind of program mess up because i transferred it to a new folder, hard drive or otherwise beyond maybe having to designate a new path, which isn’t the case here.

Regardless, I’ve reinstalled it multiple times, that doesn’t do anything and many other people who have reported this problem have reported that reinstalling does nothing but maybe get themselves one or two games before it breaks again.

I’m not running a potato. I have 16gb of DDR4 and are running an R7 2700x OC’d cpu.
Thanks but I’m not dumb enough to run a game on an ancient laptop from the 80’s then complain it’s slow to load.

If I sound like I have no patience, it’s because I don’t. Last time I asked for help with this issue I got hard harassed by people who know incredibly little about PC’s and harassed me with irrelevant things.

Most of the time, the loading bug is because of antivirus realtime scanning. The british-musket-loading screen is used for start writing the game rec file to drive.

Some solutions could be:

  1. Disable realtime scanning in your antivirus software when playing aoe3.
  2. Add your steam games folder and my games folder into your antivirus whitelist.
  3. Consider using default Windows Defender. Third party antivirus generally cause these issues.
1 Like

I kindly ask that you read a post before commenting on it. I thank you for trying to help but seriously dude.

1 Like

I updated to Windows 11 and I got into a game after only a short period of loading. I’ll be trying a few games tomorrow and will update if it was just a fluke or not. But I swear if updating to windows 11 fixed it I’m going to laugh so hard

Try to open task manager and look what’s happening while the game is loading. There you might be able to see which program is causing the slowdown.

Maybe its your friend with the antivirus.

Also, post your system configuration.

Look if you don’t know, just say so

There is no program slowing down my PC.

Did some more testing, after only a slight freeze the game loads in on Windows 11. Not going to question it and just go with it because if I see one more comment about anti viruses I’m going to lose it.

Glad it worked out!


So you rly use win 11 already?..

I hate Windows 10 so decided why not help out and join the Windows Insider program. It has bugs but so far it’s faster and uses a lot less ram passively for me than 10 was. And Age 3 started working. Not the most stable thing in the world though so I wouldn’t just say “if you’re having this problem install windows 11” lol