AOE DE fails to start on Windows 10 via Parallels 17

Preface:

I know I’m running on Windows 10 ARM which shouldn’t support 64 bit games however, Parallels did some magic and now all of my 64 bit games work, even older games like Orcs Must Die, etc. Everything except AOE DE. I’ve included all diagnostics and logs below. Happy to include anything else.

Game Version:

  • Build: 6464341
  • Platform: Steam
  • Operating System: Windows 10 ARM running on Parallels 17 on M1 Macbook
  • Gamertag: timbad2021

Issue:

Microsoft Visual C++ Runtime Library
Assertion failed!
Program: C:\Windows\SYSTEM32\prl_umdd10x64.dll
File: d:\jenkins\workspace\pdfm-17.0.1\sources\t...\ummain10.c
Line: 13821
Expression: *"not implemented"

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Use the same environment
  2. Install AOE DE via Steam and open the game

ATTACHMENTS:

:heavy_check_mark: StartupLog: Link
:heavy_check_mark: DXDIAG: Link
:heavy_check_mark: Screenshot: Unable due to limit, thought its not needed. It’s just a popup with the text I included in the Issue section.

You should haven’t upgraded your SO

Just tried with Windows 10 and got the same error

1 Like

Have have you tried installing the c++ updates? There was a package I downloaded and installed from a third-party website that included all installers up to 2020 if I’m not mistaken.

1 Like

I tried installed c++ updates from Microsoft but maybe not the same ones. Can you share a link?

Also, I used my old AOE Gold disc and installed it and it works flawlessly - Guess DE doesn’t stand up to the original lol

1 Like

My solution for Macbook M1 users is to abandon the Definitive Edition. Just grab a copy of the original game disc and install it. New doesn’t always mean better as can be seen from how buggy DE is.

Yes, I used a third-party webpage since Windows Update did not download and install them all, but only a couple. This is the link: Visual C++ Redistributable Runtimes All-in-One (July 2021) Download | TechPowerUp

If you manage to install all C++ runtimes, and after that you can play both Definitive and Original, I recommend trying the unofficial patch for the latter :+1:

I tried installing all of the C++ distributions that you provided but it’s still the same thing. Thanks for trying though.

1 Like

Sad to hear. Good thing you’ll be able to run the original game with UPatch HD, however! :slight_smile: