AoE DE on Parallels Freezes during Multiplayer

I’ve been enjoying AoE DE for over a year now, but the latest update ~Jan 2021 has resulted in multiplayer mode games freezing. I’m able to join a hosted game with friends, begin the game, and play an average of ~3 minutes before the screen locks and Parallels informs me that AoE is no longer responding.

Anyone else experiencing this? I’ve tried adjusting my graphic settings to low, rebooted, re-installed from a fresh download, and tried variations of multiplayer (2 - 4 player, map settings, mode, etc). Nothing seems to work.

Game Version: AoE DE 101.101.44834.0 6148570
Computer: Early 2020 Macbook Pro:

  • 2.4 GHz 8-Core Intel Core i9
  • 64 GB 2667 MHz DDR4
  • AMD Radeon Pro 5500M 4 GB / Intel UHD Graphics 630 1536 MB

Windows Version: 1909 (Windows 10 Home Single )
OS Build: 18363.1316

Parallels Version: 1.6.1 (21141)
Parallels Memory Allocation: 4GB

1 Like

Update 44725 doesn’t work on mac w parallels destop :: Age of Empires II: Definitive Edition Tech Issues & Support (

I don’t know if this will help you or not but several people having problems with parallels and there are a few solutions on steam forums for it


Sweet, thank you @Sscral moving this solution here for anyone searching:

  1. shut down parallels
  2. rightclick it’s icon and go configurate
  3. In topic “general” set configurations to “games only”
  4. In topic “hardware” → “CPU & Memory” choose “4” processors with 8 GB RAM
  5. Still in topic “Hardware” → “Harddisk” choose 256GB
1 Like