AoE II DE Do not launch

Good afternoon my fellow majesties.

Since the current patch from 20 of july, the game just dont launch at all.

The 3 king splash from the starting game appears, but then Steams swich the button from “Stop” to “Play”. Saying that the game didnt launch. Steps i already did which i found on this forum:

A) Check from disk space (game already instaled): 107 GB from 232 GB (Failed)
B) Tried to ignore Steam (Yes, PC Steam user here) and go directly to the local folder: Tried to launch as admin. (Failed)
C) Check for new V-Card drivers. NVidia GeForce GTX 1050. All updated (Failed)
D) Uninstall, restart the PC, Install again. (Failed 5 times)
E) Antivirus, i only use the windows 10 Security. I do not use a antivirus. All up to date and it did not blocked AoE 2 DE. (Failed)
F) Windows 10 upgrades, i installed every single upgrade posible. (Failed)
G) Steam check for corrupted files, everything running correctly (Failed)
H) Upgrade the Microsoft visual C++ for (x64), installed properly. (Failed)

Im sure im forgetting some other actions i did.
¿It is fair if i just lay at the floor and start crying now?

I hope someone else have some information about this strange topic.
Thanks for your time!

I think it is a mod that is bugged.

I dont know if you use this mod, then the solution is pretty easy.

Otherwise you mostly needs to unsubscribe from every mod and restart the game. If the game launch, you know for sure it is a mod and you can start adding back all mods to the game. If the game stops launching, then you know which mod is the issue (just dont subscribe to that mod).

If the game still not launches, then you have another problem…

1 Like

It works perfectly! Thank you very much my friend.

that is what i am getting when trying to launch game :frowning: I tried searching here in forum but no luck finding answers :frowning: Game work at first and now for no reason it wont launch :frowning: its not a steam game