AoE IIDE Update 36202 Bugs: Extreme lag in commands; Villagers not working; AI building countless shipyards

Game Version:

  • Build: 36202
  • Platform: Microsoft Store
  • Operating System: Windows 10
  • Gamertag: symbolic07


After Update 36202 was installed I tried to play against 3 AI players. However, there is huge lag in the game, everything is super slow, the commands are applied some minutes after I give them, if at all! Most of the AI-controlled villagers seem to be stuck in limbo and do not do anything. AI-controlled players started to build countless shipyards immediately after the game has begun.

Reproduction Steps:

Here is the link to my feedback in Windows Feedback


I have attached 2 videos to my feedback in Windows Feedback


I am now having the same issue, my game worked fine for months. Last night after a few matches, the input lag suddenly started and the game is unplayable. Units are unresponsive but the game continues as normal. Playing on Steam, with hardware above and beyond what’s required, 250mbps internet, it’s the game. Verified game files, reinstalled, lowered settings, everything, after 5 minutes in a game the unresponsive units input lag starts, please fix


Facing the same issue since I bought the game at the early of Feb. Have to say this is extremely annoying and it seems this issue only happens when I play w/ my friend against AI. It is kind of weird that sometimes my friend can play w/o any lag while the host(me) and AI are struggling on this. Wondering how many peoples are suffering from this and hopefully this can be resolved soon.


The game occasionally bugs out for me, sometimes it works from for awhile, but it eventually bugs out with input delay. The only thing that works is saving the game and restoring it to continue, but most times it happens within the first 10 minutes. Also, it doesn’t matter what game you play, or with who. I play 1v1 with AI and it lags. Then I played on a edited map I made, that has 8 Players and hundreds of units, buildings and details and it was fine for an hour. The difference is, I was using a modded dataset I subscribed to. I believe there is something wrong with the official dataset


Same problem, and the command lag makes the game unplayable. Really a shame - I bought this to play cooperatively with my friend against AI, and that’s exactly what doesn’t work. When we play 1v1, it works find, no command lag. But with AI opponents, the command lag starts within the first few minutes (just a few seconds lag) and exacerbates over time until the lag is several minutes before units respond to commands.